Bug 112697 - download.fedora.redhat.com/pub/ HTML and CSS style sheet errors causing mozilla browser to crash
download.fedora.redhat.com/pub/ HTML and CSS style sheet errors causing mozil...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
http://download.fedora.redhat.com/pub...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-28 20:30 EST by Kam Leo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 06:08:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 225848 None None None Never

  None (edit)
Description Kam Leo 2003-12-28 20:30:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The fedora download/update/development RPMS web pages have html and
CSS sytle sheet errors.  The errors are such that the mozilla browser
either hangs or cannot completely render these pages.  Mozilla.org has
a fix (http://bugzilla.mozilla.org/show_bug.cgi?id=225848) to handle
improperly formed web pages, but the responsibility should not be
theirs alone. 

The http://download.fedora.redhat.com/pub site should conform to W3C
standards and be able to pass the validation tests available at
http://validator.w3.org.



Version-Release number of selected component (if applicable):
mozilla-1.4.1-18 mozilla-1.5-1 mozilla-1.6b

How reproducible:
Always

Steps to Reproduce:
1. Enter
http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os/Fedora/RPMS/
into mozilla 1.4.1 browser.
2. Use any web brower and go to http://validator.w3.org.
   Enter uri from step 1 into "Address" field and click "Validate URI"
3. Again using any web browser go to http://validator.w3.org.  Click
"CSS Validator" link on right side of page.  Click "Validate your
cascading style sheet by URI".  Enter uri from step 1 and procede with
validation.

Actual Results:  
1. Mozilla hangs or renders incomplete page after minutes of waiting.
2. Web page fails W3C validation
3. CSS style sheet fails W3C validation

Expected Results:  
1. Mozilla browser to render web page in seconds, not in minutes or
hanging.  
2. Fedora web pages pass W3C validation. 

Additional info:
Comment 1 Christopher Blizzard 2004-02-12 13:37:09 EST
I've never seen this problem.
Comment 2 Christopher Aillon 2005-03-31 06:08:17 EST
The mozilla bug has been fixed upstream.  There was some discussion on
fedora-devel-list about fixing the webpage as well.
https://www.redhat.com/archives/fedora-devel-list/2005-March/msg01517.html

This bug can be closed though since its about the browser issue.

Note You need to log in before you can comment on or make changes to this bug.