Bug 1126979 - 404 ERROR
Summary: 404 ERROR
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 1.x
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Andy Goldstein
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 18:40 UTC by Miguel Angel
Modified: 2014-08-07 21:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 21:36:01 UTC


Attachments (Terms of Use)

Description Miguel Angel 2014-08-05 18:40:23 UTC
Description of problem:
HAVE A 404 ERROR

Version-Release number of selected component (if applicable):


How reproducible:

GO TO http://main-lbt1.rhcloud.com/

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Miguel Angel 2014-08-07 07:44:50 UTC
Somebody there!!!

Comment 4 Miguel Angel 2014-08-07 12:13:27 UTC
I put my easy php code in my server http://main-lbt1.rhcloud.com/
But I cannot see anything
I go to http://main-lbt1.rhcloud.com/
I get 404 error

Comment 5 Miguel Angel 2014-08-07 12:19:17 UTC
I used git to move my code

Comment 6 Miguel Angel 2014-08-07 12:19:49 UTC
Why I cannot see a simple image?

Comment 7 Miguel Angel 2014-08-07 12:35:38 UTC
I have payed the server service and I don´t have size limit

Comment 8 Dan McPherson 2014-08-07 15:32:49 UTC
Miguel,

  Do you have an index.php or index.html at the root of your git repo?

Comment 9 Miguel Angel 2014-08-07 16:13:07 UTC
yes

Comment 10 Miguel Angel 2014-08-07 16:14:12 UTC
index.php

Comment 11 Dan McPherson 2014-08-07 17:24:42 UTC
And if you ssh to your gear, do you see index.php at app-root/repo?

Comment 12 Miguel Angel 2014-08-07 17:32:15 UTC
yes

Comment 13 Andy Goldstein 2014-08-07 18:11:52 UTC
Are you able to share the contents of your .htaccess file? We believe that's what's causing the problem.

Comment 14 Miguel Angel 2014-08-07 19:27:36 UTC
I don´t thing so, I don´t have this file now

Comment 15 Miguel Angel 2014-08-07 19:28:44 UTC
Why i don´t seee http://main-lbt1.rhcloud.com/images/about.jpg???

Comment 16 Andy Goldstein 2014-08-07 19:30:00 UTC
I believe you still have an .htaccess file in place. You can SSH to your gear and look in app-root/runtime/repo to verify. I believe that is likely what is causing the problem.

Comment 17 Miguel Angel 2014-08-07 19:38:14 UTC
I don´t think so. I deleted this file. I have the same problem

Comment 18 Andy Goldstein 2014-08-07 20:22:39 UTC
Ok, I believe I've discovered what's going on. We support multiple options for the DocumentRoot for your application: php, public, public_html, web, www. If you have a directory with any of these names in your git repo, we will use that as the DocumentRoot. Because you have a "www" directory, that becomes the root. So when you try to go to http://main-lbt1.rhcloud.com/images/about.jpg, it's actually trying to serve www/images/about.jpg, which doesn't exist.

Would it be possible for you to restructure your source code to either remove the www directory, or put your code in it?

Comment 19 Miguel Angel 2014-08-07 21:03:27 UTC
I will try that

Comment 20 Miguel Angel 2014-08-07 21:36:01 UTC
thanks , now work.
thanks a lot


Note You need to log in before you can comment on or make changes to this bug.