Bug 112701 - ODBC and multiple connections
ODBC and multiple connections
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: unixODBC (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
http://ninjacoder.com/~ademko/odbc_te...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-28 23:52 EST by Aleksander Demko
Modified: 2013-07-02 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksander Demko 2003-12-28 23:52:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I can't seem to successfully open >1 DB connections via ODBC, to
PostgreSQL, under Fedora. It seems to seg fault in the oddest of
places. This code has worked fine on RH Linux <=9.

Is there something I'm supposed to enable in the odbcinst.ini file
for multiple connections to work under Fedora?

A small test program and my .odbc.ini file is attached. The program
runs fine if you comment out the second connection. isql on the DSN
also runs fine. The program runs fine on RH Linux <=9.


Version-Release number of selected component (if applicable):
unixODBC-2.2.5-9

How reproducible:
Always

Steps to Reproduce:
1. setup a postgresql user and database
2. try to run an ODBC program that opens >=2 connections at a time to
said database
    

Actual Results:  program crashes... something nullish in the ODBC systems

Expected Results:  valid creation of multiple connections. This used
to work under RHL <= 9

Additional info:

please see the URL http://ninjacoder.com/~ademko/odbc_test.c for the
test program that I'm using
Comment 1 Tom Lane 2004-03-08 12:57:34 EST
I suspect this is an artifact of the known memory-clobber problem in
unixODBC 2.2.5 (see bug #110595).  I cannot replicate the problem
using your test program with 2.2.8, which is due to ship with Fedora
Core 2.
Comment 2 Tom Lane 2004-04-05 16:37:12 EDT
I'm going to mark this bug as fixed-in-FC2, but please feel free to
reopen it if you find that it still happens with unixODBC 2.2.8 or
later.

Note You need to log in before you can comment on or make changes to this bug.