Bug 1127022 - inconsistent wifi connection at boot time
Summary: inconsistent wifi connection at boot time
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 00:03 UTC by Chris Murphy
Modified: 2015-12-02 16:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 03:21:06 UTC


Attachments (Terms of Use)
dmesg (96.42 KB, text/plain)
2014-08-06 00:04 UTC, Chris Murphy
no flags Details
lscpi -vvnn (2.61 KB, text/plain)
2014-08-06 00:04 UTC, Chris Murphy
no flags Details
journal (full) (387.07 KB, text/plain)
2014-08-06 00:05 UTC, Chris Murphy
no flags Details
journal (NetworkManager) (80.74 KB, text/plain)
2014-08-06 00:06 UTC, Chris Murphy
no flags Details
nwmdebug.txt (8.76 KB, text/plain)
2014-08-06 00:09 UTC, Chris Murphy
no flags Details
wpa_supplicant.log (36.25 KB, text/plain)
2014-08-07 19:53 UTC, Chris Murphy
no flags Details
journal (full) with debug (390.75 KB, text/plain)
2014-08-07 19:56 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-08-06 00:03:27 UTC
Description of problem: Sometimes Wifi connects at boot time, and when it does it remains connected reliably. Perhaps 50% of the time, it fails to connect at boot time for reasons I don't understand, and no wifi networks are seen at all. No applicable kernel messages.


Version-Release number of selected component (if applicable):
NetworkManager-0.9.10.0-2.git20140704.fc21
kernel-3.16.0-1.fc21.x86_64
kernel: b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)

How reproducible:
Non-determinstic. It *seems* like cold boots are more reliable than warm boots.

Steps to Reproduce:
1. Boot.

Actual results:

No wifi networks visible at all in gnome networkmanager UI.

I think this is the bottom line problem "(wlp3s0): not available because supplicant interface not ready" I just don't know the cause since there are no kernel messages.

Expected results:

Consistent connections every boot.

Additional info:

Excerpts that seem related:

[    7.109578] twenty1.localdomain NetworkManager[694]: <debug> [1407282093.902721] [nm-device-wifi.c:3230] set_enabled(): (wlp3s0): device now enabled
[    7.109764] twenty1.localdomain NetworkManager[694]: <debug> [1407282093.902875] [nm-device-wifi.c:3236] set_enabled(): (enable): wlp3s0 blocked by UNMANAGED state

[    7.110679] twenty1.localdomain NetworkManager[694]: <info> (wlp3s0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]

[    7.113394] twenty1.localdomain NetworkManager[694]: <debug> [1407282093.906191] [devices/nm-device.c:5542] nm_device_bring_up(): (wlp3s0): bringing up device.
[    7.113614] twenty1.localdomain NetworkManager[694]: <debug> [1407282093.906359] [platform/nm-platform.c:806] nm_platform_link_set_up(): link: setting up 'wlp3s0' (3)
[    7.113828] twenty1.localdomain NetworkManager[694]: <debug> [1407282093.906541] [platform/nm-linux-platform.c:2356] link_change_flags(): link: change 3: flags set 'up' (1)
[    7.309812] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.104784] [platform/nm-linux-platform.c:412] get_kernel_object(): get_kernel_object for link: wlp3s0 (3, family 0)
[    7.310137] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105228] [platform/nm-platform.c:2565] log_link(): signal: link changed: 3: wlp3s0 <UP> mtu 1500 wifi driver 'b43' udi '/sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/bcma0:0/net/wlp3s0'
[    7.310379] twenty1.localdomain NetworkManager[694]: <info> (wlp3s0): preparing device
[    7.312185] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105278] [devices/nm-device.c:6396] nm_device_remove_pending_action(): (wlp3s0): remove_pending_action (0): 'autoconf6' not pending (expected)

[    7.313920] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105690] [supplicant-manager/nm-supplicant-manager.c:90] nm_supplicant_manager_iface_get(): (wlp3s0): creating new supplicant interface
[    7.314163] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105806] [supplicant-manager/nm-supplicant-interface.c:881] interface_add(): (wlp3s0): adding interface to supplicant
[    7.314401] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105882] [devices/nm-device.c:6342] nm_device_add_pending_action(): (wlp3s0): add_pending_action (1): 'waiting for supplicant'
[    7.314671] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105898] [nm-manager.c:718] check_if_startup_complete(): check_if_startup_complete returns FALSE because of enp2s0f0
[    7.314910] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105917] [nm-device-wifi.c:1192] is_available(): (wlp3s0): not available because supplicant interface not ready
[    7.315165] twenty1.localdomain NetworkManager[694]: <debug> [1407282094.105924] [devices/nm-device.c:6705] _set_state_full(): (wlp3s0): device not yet available for transition to DISCONNECTED

Comment 1 Chris Murphy 2014-08-06 00:04:28 UTC
Created attachment 924302 [details]
dmesg

Comment 2 Chris Murphy 2014-08-06 00:04:57 UTC
Created attachment 924303 [details]
lscpi -vvnn

03:00.0 Network controller [0280]: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)
	Subsystem: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331]

Comment 3 Chris Murphy 2014-08-06 00:05:58 UTC
Created attachment 924304 [details]
journal (full)

journalctl -b -l -o short-monotonic

Comment 4 Chris Murphy 2014-08-06 00:06:19 UTC
Created attachment 924305 [details]
journal (NetworkManager)

journalctl -b -l -o short-monotonic -u NetworkManager

Comment 5 Chris Murphy 2014-08-06 00:09:12 UTC
Created attachment 924306 [details]
nwmdebug.txt

Enabled level=DEBUG in NetworkManager.conf, restarted NetworkManager, used the GUI to turn off the WiFi radio, started a journalctl -f -u NetworkManager capture, and then turned the WiFi back on and waited for about a minute. Result attached.

Even after turning it off then on, I still get the same results. So far 100% of the time *if* at boot time wireless isn't working, I can't make it work post-boot. If it works at boot time, I can't make it fail. So it seems like it might be a kernel problem, yet I'm not getting any kernel messages which I'd sorta expect if there are kernel-hardware related problems. *shrug*

Comment 6 Chris Murphy 2014-08-06 00:36:31 UTC
This might be a manifestation of bug 1061836, despite no kernel messages. I'm not sure if that bug shows messages only with debug kernels.

Comment 7 Chris Murphy 2014-08-07 19:53:20 UTC
Created attachment 925014 [details]
wpa_supplicant.log

I added -dd to /etc/wpa_supplicant/wpa_supplicant.conf

[root@twenty1 chris]# systemctl status wpa_supplicant
● wpa_supplicant.service - WPA Supplicant daemon
   Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled)
   Active: active (running) since Thu 2014-08-07 13:18:29 MDT; 8min ago
 Main PID: 810 (wpa_supplicant)
   CGroup: /system.slice/wpa_supplicant.service
           └─810 /usr/sbin/wpa_supplicant -u -f /var/log/wpa_supplicant.log -c /etc/wpa_supplicant/wpa_supplicant.conf -dd -u -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplic...

Comment 8 Chris Murphy 2014-08-07 19:56:11 UTC
Created attachment 925015 [details]
journal (full) with debug

NetworkManager set to debug, as well as wpa_supplicant. This journal goes with the previously attached wpa_supplicant.log.

So far all cold boots have working wifi, while most warm boots don't. Once the problem starts, it's looking like it needs a shutdown to resolve the problem.

Comment 9 Jirka Klimes 2014-08-19 12:50:30 UTC
Any better with newest kernel and wpa_supplicant? Did you try with another card (a USB Wi-Fi dongle)?

Please check whether the Wi-Fi is not blocked:
$ rfkill list
# rfkill unblock all

$ nmcli general
$ nmcli radio wifi on

Comment 10 Chris Murphy 2014-08-22 02:01:54 UTC
kernel-3.16.0-1.fc21.x86_64
wpa_supplicant-2.0-9.fc21.x86_64
NetworkManager-0.9.10.0-3.git20140704.fc21.x86_64

Same kernel as before but I think newer wpa_supplicant (? not sure since I didn't previously report its version), and newer NetworkManager. I've only tried a few times so far, but warm reboots do have working wireless with this combination; previously it was completely consistent that I'd have to power off and cold boot to resolve the problem. So it's looking better so far.

Comment 11 Chris Murphy 2014-08-24 04:07:15 UTC
OK it happened again on a warm boot.

# rfkill list
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
# rfkill unblock all
# nmcli general
STATE                   CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
connected (local only)  limited       enabled  enabled  enabled  enabled 
# nmcli radio wifi on

No change. I have to cold boot to resolve it.

Comment 12 Fedora Admin XMLRPC Client 2015-08-18 14:57:32 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 13 Fedora End Of Life 2015-11-04 10:48:58 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 14 Fedora End Of Life 2015-12-02 03:21:09 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.