Bug 1127075 - Add ability to set the cipher suites and protocols used for SSL
Summary: Add ability to set the cipher suites and protocols used for SSL
Keywords:
Status: CLOSED DUPLICATE of bug 1165463
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: EAP 6.4.3
Assignee: Justin Bertram
QA Contact: Miroslav Novak
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 05:04 UTC by varsha
Modified: 2019-06-13 08:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-10 02:54:26 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker HORNETQ-1288 Major Resolved Add ability to set the cipher suites and protocols used for SSL 2016-05-25 23:52:10 UTC
Red Hat Bugzilla 1241730 None None None Never

Internal Links: 1241730

Description varsha 2014-08-06 05:04:01 UTC
Description of problem:

Add ability to set the cipher suites and protocols used for SSL. This is resolved in HORNETQ-1288.

How reproducible:
Currently there is no way to set the cipher suites used for SSL.

Comment 1 Justin Bertram 2014-09-10 18:09:17 UTC
The ability to set the cipher suites and protocols used for SSL is a new feature that can't simply be added to EAP at any point.  If I'm not mistaken this needs to go through the RFE process (which is a GSS task).  If the RFE is approved I'll be happy to back-port this functionality to the 2.3.x branch of HornetQ for use in EAP 6.x.

Varsha, please initiate the RFE process if you think the customer really wants this functionality in EAP 6.x.

Comment 3 Jason Shepherd 2015-07-10 02:54:26 UTC

*** This bug has been marked as a duplicate of bug 1165463 ***


Note You need to log in before you can comment on or make changes to this bug.