Bug 1127097 - wrongly searching for device id in audio test
Summary: wrongly searching for device id in audio test
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.6.5
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Guangze Bai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 07:02 UTC by garrickyang
Modified: 2015-02-08 21:39 UTC (History)
5 users (show)

Fixed In Version: hwcert-client-1.6.5.2-20140817.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 08:09:19 UTC


Attachments (Terms of Use)
audio.py (6.53 KB, text/plain)
2014-08-14 15:36 UTC, Guangze Bai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1079 normal SHIPPED_LIVE hwcert-client-1.6.5 bug fix update 2014-08-20 12:09:00 UTC

Description garrickyang 2014-08-06 07:02:41 UTC
Description of problem:
hwcert-backend tool can't support to test integrated HDMI audio in RHEL 6.5.
When run hdmi audio test, hwcert-backend reports "Error: aplay command failed". But in fact, I can hear sound via HDMI audio when play sounds with "Sound Preferences" or run command "aplay /usr/share/sounds/alsa/Front_Right.wav -D plughw:0,3".
And output of "aplay -l":
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC662 rev3 Analog [ALC662 rev3 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Part of hwcert-backend output:
This test plays a sound sample and records it to another file.
Please use the Volume Control application and insure that the 
Capture settings will record the sound.
Continue? (y|n) response: y
starting recording while playing demo sound
Error: aplay command failed

How reproducible:
always

Steps to Reproduce:
1.Install RHEL 6.5 64bit and hwcert.
2.run hdmi audio test with command:"hwcert-backend run --test=audio --udi=pci0000:00/0000:00:03.0/sound/card0"
3.Check the hwcert-backend output.

Actual results:
Failed to test integrated HDMI audio.

Expected results:
Can test this device, and HDMI monitor should play the sounds.

Additional info:
Config:
Processor:Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
Memory: 8GB
Chipset:Intel C226
hwcert version: 1.6.5.2, release 20140611

Comment 1 Guangze Bai 2014-08-14 15:36:15 UTC
Created attachment 926853 [details]
audio.py

Hi,

Could you move this attached file to /usr/share/hwcert/tests/audio and re-run the test and feedback here again?

Thanks

Comment 2 garrickyang 2014-08-15 02:03:00 UTC
(In reply to Guangze Bai from comment #1)
> Created attachment 926853 [details]
> audio.py
> 
> Hi,
> 
> Could you move this attached file to /usr/share/hwcert/tests/audio and
> re-run the test and feedback here again?

It's tested "pass" with this file.
When will this version be released?

> 
> Thanks

Comment 3 Guangze Bai 2014-08-15 03:00:12 UTC
Thanks for your feedback. We'll release as soon as possible.

Comment 12 errata-xmlrpc 2014-08-20 08:09:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1079.html


Note You need to log in before you can comment on or make changes to this bug.