Bug 11271 - Qt 2.1.0 (final) corrects problems in 2.1.0beta1
Summary: Qt 2.1.0 (final) corrects problems in 2.1.0beta1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-07 05:50 UTC by James Ralston
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-07 05:56:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (1.23 KB, patch)
2000-05-07 05:56 UTC, James Ralston
no flags Details | Diff

Description James Ralston 2000-05-07 05:50:07 UTC
I've been encountering a few problems in the Qt GUI toolkit (version
2.1.0beta1).  Specifically, there are bugs in the beta version that are
affecting certain apps (notably, licq) that I'm using.

I've been following threads concerning these problems on the licq mailing
list, and the consensus is that the most recent release of Qt (that is, the
2.1.0 release, which is now out of beta) corrects these problems.

Indeed, I took the qt-2.1.0-4.beta1.src.rpm, changed it to use the
production release of Qt 2.1.0, and then rebuilt it.  It corrects the licq
problems I've been experiencing, and so far, I've encountered no side
effects.

Please consider releasing a qt-2.1.0-5 RPM as a 6.2 Bug Fix update.  This
would make me happy (I try not to deviate from standard Red Hat releases if
I can help it; it makes it too much a pain to keep track of how my system
differs from the standard release system), and would make people happy who
have neither the skills nor inclination to update their RPMs themselves.
;)

Comment 1 James Ralston 2000-05-07 05:56:59 UTC
Created attachment 223 [details]
Spec file patch

Comment 2 Bernhard Rosenkraenzer 2000-06-17 16:30:00 UTC
Thanks - it's fixed in Rawhide (using 2.1.1 with some minor fixes).
We can't release an update for 6.2 because that would require releasing updates
for all packages linked to it - they're not fully binary compatible
unfortunately.

Comment 3 David Lawrence 2008-01-25 19:43:11 UTC
Comment on attachment 223 [details]
Spec file patch

Comment moved from attachments description:

BTW, here are the changes I needed to make to the spec file.  The "make
symlinks" addition (to remake all of the symlinks in the "include"
subdirectory) is important; the qt-x11-2.1.0.tar.gz distribution comes with a
pre-built "include" subdirectory that has two symbolic links (qt_mac.h and
qt_windows.h) that point to non-existent files.  If those bogus 
symlinks are not removed (which the "make symlinks" step takes care of), the
"install" phase of building the RPM will fail.


Note You need to log in before you can comment on or make changes to this bug.