Bug 112710 - not retaining the file permission.
not retaining the file permission.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: dos2unix (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 10:31 EST by RamaSubbu SK
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 20:35:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaSubbu SK 2003-12-29 10:31:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Good: dos2unix and unix2dos all these utilies are not retaining the
file permission. Always it is seeting to u+rw only. 


Version-Release number of selected component (if applicable):
dos2unix-3.1

How reproducible:
Always

Steps to Reproduce:
1. create a file with permission -rwxrwxrwx ( chmod 777 test.txt )
2. execute dos2unix against the file (dos2unix text.txt)
3. now, check for the file permission. it will -rw------- 
    

Actual Results:  Original file permission is not retained, it is
getting changed.

Expected Results:  File permission should not be changed.. Should
retain the original settings.

Additional info:

This we can also consider as an Enhancement, it is in the way how we
are taking into. I can also fix this issue,( as the fix is very small
) if I can have the CVS access to this utility.
Comment 1 Miloslav Trmac 2004-02-06 13:19:05 EST

*** This bug has been marked as a duplicate of 91331 ***
Comment 2 Tim Powers 2005-05-19 20:35:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html

Note You need to log in before you can comment on or make changes to this bug.