Bug 1127104 - fbdev refusing to touch /dev/fb0 on legacy probe path
Summary: fbdev refusing to touch /dev/fb0 on legacy probe path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 07:33 UTC by Tomas Pelka
Modified: 2014-10-14 04:56 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.15.0-17.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:56:53 UTC


Attachments (Terms of Use)
xorg.conf (2.82 KB, text/plain)
2014-08-06 07:35 UTC, Tomas Pelka
no flags Details
Xorg.log (6.27 KB, text/plain)
2014-08-06 07:35 UTC, Tomas Pelka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1376 normal SHIPPED_LIVE xcb-util, xorg-x11-drivers, and mesa bug fix and enhancement update 2014-10-14 01:11:03 UTC

Description Tomas Pelka 2014-08-06 07:33:50 UTC
Description of problem:
I'm not able to configure fbdev.

Version-Release number of selected component (if applicable):
xorg-x11-drv-fbdev-0.4.3-15.el6
xorg-x11-server-Xorg-1.15.0-17.el6

How reproducible:
100%

Steps to Reproduce:
1. generate xorg.conf by Xorg :1 -configure
2. edit the ~/xorg.conf.new and replace driver to fbdev (my xorg.conf attached)
3. place xorg.conf.new to /etc/x11/xorg.conf

Actual results:
[  1051.734] (II) LoadModule: "fbdev"
[  1051.734] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[  1051.734] (II) Module fbdev: vendor="X.Org Foundation"
[  1051.734] 	compiled for 1.15.0, module version = 0.4.3
[  1051.734] 	Module class: X.Org Video Driver
[  1051.734] 	ABI class: X.Org Video Driver, version 15.0
[  1051.734] (II) FBDEV: driver for framebuffer: fbdev
[  1051.734] (++) using VT number 1

[  1051.734] (II) Loading sub module "fbdevhw"
[  1051.734] (II) LoadModule: "fbdevhw"
[  1051.734] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[  1051.734] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1051.734] 	compiled for 1.15.0, module version = 0.0.2
[  1051.734] 	ABI class: X.Org Video Driver, version 15.0
[  1051.734] (EE) Refusing to touch /dev/fb0 on legacy probe path
[  1051.734] (EE) Please specify a BusID to use this device
[  1051.734] (WW) Falling back to old probe method for fbdev
[  1051.734] (II) Loading sub module "fbdevhw"
[  1051.734] (II) LoadModule: "fbdevhw"
[  1051.734] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[  1051.734] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1051.734] 	compiled for 1.15.0, module version = 0.0.2
[  1051.734] 	ABI class: X.Org Video Driver, version 15.0
[  1051.734] (EE) Refusing to touch /dev/fb0 on legacy probe path
[  1051.734] (EE) Please specify a BusID to use this device
[  1051.734] (EE) Screen 0 deleted because of no matching config section.
[  1051.734] (II) UnloadModule: "fbdev"
[  1051.734] (II) UnloadSubModule: "fbdevhw"
[  1051.734] (EE) Device(s) detected, but none match those in the config file.
[  1051.734] (EE) 
Fatal server error:
[  1051.734] (EE) no screens found(EE) 
[  1051.734] (EE) 

Expected results:
it should work

Additional info:

Comment 1 Tomas Pelka 2014-08-06 07:35:23 UTC
Created attachment 924373 [details]
xorg.conf

Comment 2 Tomas Pelka 2014-08-06 07:35:48 UTC
Created attachment 924374 [details]
Xorg.log

Comment 4 Dave Airlie 2014-08-11 03:28:48 UTC
transferring to ajax, even though this will STUPIDLY lose the acks.

ajax, patch 9205 0001-xfree86-Allow-mixed-fbdev-and-pci-setups.patch breaks xorg starting with a simple xorg.conf with jsut fbdev in it.

I rebuilt locally without this patch and it works fine.

Comment 6 Adam Jackson 2014-08-11 16:37:14 UTC
Yeah, this is an fbdev bug really.  Its PciProbe hook doesn't bother to pass the pci device into fbdevhw, so the "am I on the legacy path" logic breaks down.

None of the other fbdevhw drivers call fbdevHWProbe.  Besides fbdev only glint calls fbdevHWInit with a null second argument (technically a thing that can't matter in RHEL since we don't build the 3dlabs fbdev drivers).  I've pushed fixes for both upstream (since the change is harmless without the RHEL patch) rebuilt the drivers for 6.6.

Comment 9 Tomas Pelka 2014-09-01 06:55:35 UTC
*** Bug 1134860 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2014-10-14 04:56:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1376.html


Note You need to log in before you can comment on or make changes to this bug.