Bug 112711 - Kernel-2.6.0-1.21 boot problems
Kernel-2.6.0-1.21 boot problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 12:03 EST by Sammy
Modified: 2015-01-04 17:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Trace dump from kernel panic (985 bytes, text/plain)
2004-01-03 06:59 EST, Michel Alexandre Salim
no flags Details

  None (edit)
Description Sammy 2003-12-29 12:03:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; , en_US, en)

Description of problem:
A number of problems is preventing me to boot this version (after
figuring out the mkinitrd problem!):

1. I get a kernel panic when mounting the following device: 

/dev/vg01/lv_data       /data                   ext3    defaults        1 2

from fstab. The device file is there. I am not sure what this is for since it
came from Dell as part of the preinstalled linux. It seems to be empty.

2. The /boot/vmlinux-version points to the wrong location /usr/lib/debig/lib/modules/vmlinux-version... which does not exist!
Also, /lib/modules/kernel-version/vmlinux* does not exits either!

Version-Release number of selected component (if applicable):
kernel-2.6.0-1.2smp

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-2.6.0-1.2
2. boot
3.
    

Actual Results:  kernel panic

Expected Results:  system start

Additional info:
Comment 1 Arjan van de Ven 2003-12-29 12:12:28 EST
the vmlinuX file is only useful if you want to run gdb on the kernel
and is HUGE so we stuck it in the debuginfo rpm only (99.9999% of the
people don't need it and it'd be a waste of space and bandwidth for them)
Comment 2 Sammy 2003-12-29 16:29:23 EST
Ok...I have /boot and / as different partitions. The boot comes all the 
way to before calling init and gives an error saying unable to mount 
root partition, and than it panics because it cannot find init. The 2.4 
kernel works fine with this setting. Here is my grub.conf file: 
------------------------------------------------ 
splashimage=(hd0,2)/grub/splash.xpm.gz 
title Fedora Core (2.6.0-1.21smp) 
        root (hd0,2) 
        kernel /vmlinuz-2.6.0-1.21smp ro root=/dev/sda5  hdc=ide-scsi 
        initrd /initrd-2.6.0-1.21smp.img 
title Fedora Core (2.4.22-1.2129.nptlsmp) 
        root (hd0,2) 
        kernel /vmlinuz-2.4.22-1.2129.nptlsmp ro root=/dev/sda5 hdc=ide-scsi 
        initrd /initrd-2.4.22-1.2129.nptlsmp.img 
 
Comment 3 Michel Alexandre Salim 2004-01-03 06:59:37 EST
Created attachment 96749 [details]
Trace dump from kernel panic
Comment 4 Michel Alexandre Salim 2004-01-03 07:04:10 EST
I get the <a
href="https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=96749&action=view">attached</a>
kernel panic booting 2.6.0-1.21 (i686) on my Vaio Z1MP (Pentium-M 1.3
GHz, 768MB RAM, 40GB HDD, running Fedora Core 1 with updated mkinitrd
and selinux packages). I recall running 2.6.0 test kernels just fine a
few months ago, and the exact same panic is reproducible when booting
with pci=noacpi and acpi=off

Downloading -1.23 now to see if this is fixed.
Comment 5 Arjan van de Ven 2004-01-03 07:06:54 EST
It seems Dave enabled PNPBIOS by mistake....
try booting with pnpbios=off on the commandline (and you need to
remove the ide-scsi part as well for 2.6...)
Comment 6 Michel Alexandre Salim 2004-01-03 21:57:06 EST
PNPBIOS was the culprit, thanks. I *knew* I was missing something
after trying acpi= and pci=, but could not remember what. Same problem
with -1.23 too - and as for ide-scsi, I thought it's not even needed
with FC1 kernels?

Note You need to log in before you can comment on or make changes to this bug.