Bug 1127118 - Fix PR61801 in GCC 4.4-RH
Summary: Fix PR61801 in GCC 4.4-RH
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks: 1127120
TreeView+ depends on / blocked
 
Reported: 2014-08-06 08:19 UTC by Jakub Jelinek
Modified: 2014-10-14 05:01 UTC (History)
4 users (show)

Fixed In Version: gcc-4.4.7-10.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Clone Of:
: 1127120 (view as bug list)
Environment:
Last Closed: 2014-10-14 05:01:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1377 normal SHIPPED_LIVE gcc bug fix and enhancement update 2014-10-14 01:06:11 UTC

Description Jakub Jelinek 2014-08-06 08:19:54 UTC
GCC 4.4-RH has -fvar-tracking-assignments backported to it, and with that also the http://gcc.gnu.org/PR61801 bug that showed up on the Linux kernel as a wrong-code issue.  While the exact testcase from that PR doesn't seem to fail with 4.4-RH, the bug is still there and should be fixed, because it could affect other code, in the kernel or elsewhere, at least in theory.

Comment 2 Jakub Jelinek 2014-08-06 18:08:16 UTC
The testcase from PR61801 is included, but as I said earlier, didn't happen to fail without the fix, so this has to be checked just that it has been applied and no regressions in %check (verified that already).

Comment 3 errata-xmlrpc 2014-10-14 05:01:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1377.html


Note You need to log in before you can comment on or make changes to this bug.