Bug 1127124 - [Jboss-AMQ]Prompt lots of meaningless information when A-MQ password is less than 6 characters
Summary: [Jboss-AMQ]Prompt lots of meaningless information when A-MQ password is less ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Fuse
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Hiram Chirino
QA Contact: David Simansky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 08:29 UTC by xjia
Modified: 2016-10-28 13:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 13:54:53 UTC


Attachments (Terms of Use)

Description xjia 2014-08-06 08:29:29 UTC
Description of problem:
Set OPENSHIFT_AMQ_PASSWORD=admin when create A-MQ app. it will show lots of warning messages(more than one thousand lines). Please optimize it.

Version-Release number of selected component (if applicable):
openshift-origin-cartridge-amq-6.1.0.redhat.387-6.el6op.noarch.rpm
openshift-origin-cartridge-fuse-6.1.0.redhat.387-6.el6op.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.  rhc app create amq amq -e OPENSHIFT_AMQ_PASSWORD=admin

Actual results:
[root@broker ~]# rhc app create amq amq -e OPENSHIFT_AMQ_PASSWORD=admin
Using jboss-amq-6.1.0 (JBoss AMQ 6.1.0 EA) for 'amq'

Application Options
-------------------
Domain:                xuan
Cartridges:            jboss-amq-6.1.0
Gear Size:             default
Scaling:               no
Environment Variables: OPENSHIFT_AMQ_PASSWORD=admin

Creating application 'amq' ... 
Archive:  jboss-a-mq-6.1.0.redhat-387.zip
   creating: jboss-a-mq-6.1.0.redhat-387/
   creating: jboss-a-mq-6.1.0.redhat-387/fabric/
   creating: jboss-a-mq-6.1.0.redhat-387/fabric/import/
<--snip-->
 extracting: jboss-a-mq-6.1.0.redhat-387/lib/patch-client.jar  
 extracting: jboss-a-mq-6.1.0.redhat-387/extras/mq-client.jar  
keytool error: java.lang.Exception: Key password must be at least 6 characters
Unable to complete the requested operation due to: An invalid exit code (157) was returned from the server node.fuse.com.  This indicates an unexpected problem during
the execution of your request.
Reference ID: aac7c189703782d4c834e61e4b81aaee

Expected results:
[root@broker ~]# rhc app create amq amq -e OPENSHIFT_AMQ_PASSWORD=admin
Using jboss-amq-6.1.0 (JBoss AMQ 6.1.0 EA) for 'amq'

Application Options
-------------------
Domain:                xuan
Cartridges:            jboss-amq-6.1.0
Gear Size:             default
Scaling:               no
Environment Variables: OPENSHIFT_AMQ_PASSWORD=admin

Creating application 'amq' ... 
Key password must be at least 6 characters

Addition Info:

Comment 2 Aileen 2014-08-21 16:05:45 UTC
Cart should check length and report error.

Comment 3 xjia 2014-08-26 06:11:16 UTC
Version:
openshift-origin-cartridge-amq-6.1.0.redhat.390-1.el6op.noarch.rpm

[root@broker ~]# rhc app create amq amq -e OPENSHIFT_FUSE_PASSWORD=admin
Using amq-1.0.0 (JBoss AMQ 6.1.0 EA) for 'amq'

Application Options
-------------------
Domain:                fuse
Cartridges:            amq-1.0.0
Gear Size:             default
Scaling:               no
Environment Variables: OPENSHIFT_FUSE_PASSWORD=admin

Creating application 'amq' ... 
ENV_VAR_ADD: OPENSHIFT_FUSE_DOMAIN_CONSOLE_URL=https://amq-fuse.fuse-vsphere.com
keytool error: java.lang.Exception: Key password must be at least 6 characters
Command Failed: provided password must be at least 6 characters
/var/lib/openshift/53fc24a11018d62c1e0004fb/amq/bin/install: line 139: [: -gte: binary operator expected

Comment 4 Hiram Chirino 2014-08-26 12:58:38 UTC
The '-gte: binary operator expected' error should be fixed in the next build.

Comment 5 Anne-Louise Tangring 2014-08-28 13:02:43 UTC
This should be a quick or easy fix that we should do if we have time.

Comment 6 xjia 2014-09-01 07:17:23 UTC
Version:
openshift-origin-cartridge-amq-6.1.0.redhat.391-1.el6op.noarch.rpm

Verify:
[root@broker ~]# rhc app create amq amq -e OPENSHIFT_FUSE_PASSWORD=admin
Using amq-1.0.0 (JBoss AMQ 6.1.0 EA) for 'amq'

Application Options
-------------------
Domain:                amq
Cartridges:            amq-1.0.0
Gear Size:             default
Scaling:               no
Environment Variables: OPENSHIFT_FUSE_PASSWORD=admin

Creating application 'amq' ... 
Command Failed: provided password must be at least 6 characters


Note You need to log in before you can comment on or make changes to this bug.