Bug 1127132 - [abrt] yum: sqlutils.py:166:executeSQLQmark:DatabaseError: file is encrypted or is not a database
Summary: [abrt] yum: sqlutils.py:166:executeSQLQmark:DatabaseError: file is encrypted ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0881164027df9a5009025ab1743...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 08:39 UTC by Husam Abdullah
Modified: 2014-08-06 12:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 12:36:10 UTC


Attachments (Terms of Use)
File: backtrace (1.51 KB, text/plain)
2014-08-06 08:39 UTC, Husam Abdullah
no flags Details
File: environ (2.92 KB, text/plain)
2014-08-06 08:39 UTC, Husam Abdullah
no flags Details

Description Husam Abdullah 2014-08-06 08:39:50 UTC
Description of problem:
this problem appear when i use : yum update or yum install any package

Version-Release number of selected component:
yum-3.4.3-152.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /usr/bin/yum update
executable:     /usr/bin/yum
kernel:         3.15.5-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
sqlutils.py:166:executeSQLQmark:DatabaseError: file is encrypted or is not a database

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 371, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 277, in main
    return_code = base.doTransaction(inhibit=inhibit)
  File "/usr/share/yum-cli/cli.py", line 797, in doTransaction
    resultobject = self.runTransaction(cb=cb)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1776, in runTransaction
    lastdbv = self.history.last()
  File "/usr/lib/python2.7/site-packages/yum/history.py", line 1267, in last
    ret = self.old([], 1, complete_transactions_only)
  File "/usr/lib/python2.7/site-packages/yum/history.py", line 1216, in old
    executeSQL(cur, sql, params)
  File "/usr/lib/python2.7/site-packages/yum/sqlutils.py", line 166, in executeSQLQmark
    return cursor.execute(query)
DatabaseError: file is encrypted or is not a database

Local variables in innermost frame:
cursor: <sqlite3.Cursor object at 0x38e9d50>
query: 'SELECT tid,\n                         trans_beg.timestamp AS beg_ts,\n                         trans_beg.rpmdb_version AS beg_rv,\n                         trans_end.timestamp AS end_ts,\n                         trans_end.rpmdb_version AS end_rv,\n                         loginuid, return_code\n                  FROM trans_beg JOIN trans_end USING(tid) ORDER BY tid DESC LIMIT 1'
params: None

Comment 1 Husam Abdullah 2014-08-06 08:39:53 UTC
Created attachment 924397 [details]
File: backtrace

Comment 2 Husam Abdullah 2014-08-06 08:39:55 UTC
Created attachment 924398 [details]
File: environ

Comment 3 Valentina Mukhamedzhanova 2014-08-06 12:36:10 UTC
I believe the root cause of the problem here is the same as in bug 1127133.


Note You need to log in before you can comment on or make changes to this bug.