Bug 1127144 - multiple error repos when yum repolist --enablerepo=* against rhel6.6 beta workstation x86-64
Summary: multiple error repos when yum repolist --enablerepo=* against rhel6.6 beta wo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 1127143
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 09:08 UTC by haiwang
Modified: 2015-04-13 22:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1127143
Environment:
Last Closed: 2014-10-14 04:30:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1405 normal SHIPPED_LIVE redhat-release-server bug fix and enhancement update 2014-10-14 00:54:58 UTC

Description haiwang 2014-08-06 09:08:17 UTC
Description of problem:

multiple error repos when yum repolist --enablerepo=* against rhel6.6 beta workstation x86-64
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.#subscription-manager register --username=stage_rhscl_dts_test --password='redhat'
The system has been registered with ID: 21a9f6f8-c242-4362-8aae-ac86a325394f
2.#subscription-manager subscribe --pool=8a99f98146d4423f0146d98013dd0219
Successfully attached a subscription for: Red Hat Enterprise Linux Workstation, Standard
3.yum repolist --enablerepo=*

Actual results:
  Here are the error repos (total: 31)
 repo: rhel-6-workstation-rhev-agent-beta-debug-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhev-agent/3/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-debug-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-optional-debug-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/optional/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-optional-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/optional/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-optional-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/optional/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rh-common-debug-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rh-common/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rh-common-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rh-common/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rh-common-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rh-common/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhev-agent-beta-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhev-agent/3/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhev-agent-beta-source-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhev-agent/3/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhev-agent-debug-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rhev-agent/3/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhev-agent-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rhev-agent/3/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhev-agent-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rhev-agent/3/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhn-tools-beta-debug-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhn-tools/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhn-tools-beta-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhn-tools/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhn-tools-beta-source-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhn-tools/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhn-tools-debug-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rhn-tools/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhn-tools-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rhn-tools/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rhn-tools-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/rhn-tools/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-supplementary-debuginfo
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/supplementary/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-supplementary-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/supplementary/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-supplementary-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/supplementary/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-thirdparty-oracle-java-beta-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/oracle-java/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-thirdparty-oracle-java-beta-source-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/oracle-java/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-thirdparty-oracle-java-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/oracle-java/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-6-workstation-thirdparty-oracle-java-source-rpms
       https://cdn.redhat.com/content/dist/rhel/workstation/6/6.6/x86_64/oracle-java/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-workstation-rhscl-6-beta-debug-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhscl/1/debug/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-workstation-rhscl-6-beta-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhscl/1/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M
 repo: rhel-workstation-rhscl-6-beta-source-rpms
       https://cdn.redhat.com/content/beta/rhel/workstation/6/6.6/x86_64/rhscl/1/source/SRPMS/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"^M

Expected results:


Additional info:

Comment 1 Lubos Kocman 2014-08-06 11:36:56 UTC
Anything containing */dist/*/*/6/6.6/* in path is expected not to be available. Since the latest RHEL-6 in dist is 6.5. Hope it makes sense

I've rsynced following */beta/*/*/6/6.6/* repos

rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhn-tools/debug to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhev-agent/3/source/SRPMS to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/oracle-java/source/SRPMS to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/oracle-java/os to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhn-tools/os to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhscl/1/source/SRPMS to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhev-agent/3/os to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhn-tools/source/SRPMS to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhscl/1/debug to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhscl/1/os to prod
rsyncing /mnt/redhat/cds/prod/content/beta/rhel/workstation/6/6.6/x86_64/rhev-agent/3/debug to prod

Comment 3 errata-xmlrpc 2014-10-14 04:30:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1405.html


Note You need to log in before you can comment on or make changes to this bug.