Bug 1127148 - Regression test failure while running bug-918437-sh-mtime.t
Summary: Regression test failure while running bug-918437-sh-mtime.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 09:28 UTC by Jiffin
Modified: 2015-05-14 17:43 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:27:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jiffin 2014-08-06 09:28:57 UTC
Description of problem:

./tests/bugs/bug-918437-sh-mtime.t failed on gluster build system with the following error :
stat: cannot stat `/d/backends/gfs0/brick02/b': No such file or directory
[11:16:05] ./tests/bugs/bug-918437-sh-mtime.t ................

It seems that file being checked after performing self heal is wrong.

Test Summary Report
-------------------
./tests/bugs/bug-918437-sh-mtime.t              (Wstat: 0 Tests: 37 Failed: 1)
  Failed test:  37
Files=271, Tests=7911, 4619 wallclock secs ( 2.95 usr  1.75 sys + 426.03 cusr 593.78 csys = 1024.51 CPU)
Result: FAIL
+ RET=1
++ ls -l '/core.*'
++ wc -l
+ cur_count=0
+ '[' 0 '!=' 0 ']'
+ '[' 1 -ne 0 ']'
+ filename=logs/glusterfs-logs-20140805:10:09:52.tgz
+ tar -czf /archives/logs/glusterfs-logs-20140805:10:09:52.tgz /var/log/glusterfs
tar: Removing leading `/' from member names
+ echo Logs archived in http://slave24.cloud.gluster.org/logs/glusterfs-logs-20140805:10:09:52.tgz
Logs archived in http://slave24.cloud.gluster.org/logs/glusterfs-logs-20140805:10:09:52.tgz
+ exit 1
+ RET=1
+ '[' 1 = 0 ']'
+ V=-1
+ VERDICT=FAILED
+ ssh build@review.gluster.org gerrit review --message ''\''http://build.gluster.org/job/rackspace-regression-2GB-triggered/688/consoleFull : FAILED'\''' --project=glusterfs --verified=-1 --code-review=0 843c006d2ba4a58fa04ba1e040467f9d06954ced
+ exit 1
Build step 'Execute shell' marked build as failure
Finished: FAILURE

Version-Release number of selected component (if applicable):
main line


How reproducible:
Regression test by gluster bulid system

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-08-13 05:02:31 UTC
REVIEW: http://review.gluster.org/8465 (tests: trigger entry heals by lookup) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Anand Avati 2014-08-13 09:53:07 UTC
COMMIT: http://review.gluster.org/8465 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 250210a36bfd5b5c44ad49ca1c3f6aef148da322
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Aug 13 10:17:50 2014 +0530

    tests: trigger entry heals by lookup
    
    Trigger entry heals explicitly by lookup until heal full is fixed in
    afr v2 to do conservative merge.
    
    Change-Id: I474b518045bebcf399bc414caff3b415259381d6
    BUG: 1127148
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/8465
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:27:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:43:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.