Bug 112717 - lib64 libraries not in a default loader path
lib64 libraries not in a default loader path
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 15:05 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 17:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2003-12-29 15:05:26 EST
Description of problem:
A fresh installation of FC1 (prerelease) on x86_64 has troubles
booting into any other level but 1.  The immediate reason is
that PAM libraries cannot be found but this is caused by that
that /lib64 locations, or /usr/lib64, or both, are not searched
by a loader.  A workaround is to boot single, edit accordingly
/etc/ld.so.conf and rerun ldconfig.  There are no troubles
after that; but one would think that "lib64" directories should
be looked at by default on that platform.

Version-Release number of selected component (if applicable):
glibc-2.3.2-101.1
Comment 1 Jakub Jelinek 2003-12-29 15:16:04 EST
They are looked by default, unless you install 32-bit /sbin/ldconfig.
Only 64-bit /sbin/ldconfig handles both.
rpm ATM doesn't handle arch preferences too well, so you (or the installer)
need to make sure that glibc-2.3.*.x86_64.rpm is installed after
glibc-2.3.*.i686.rpm.
Comment 2 Jeremy Katz 2003-12-29 16:27:46 EST
This is (probably) because the header list doesn't have an ordering
for every package in it.  Then, we fall back to calling ts.order which
makes no guarantee on how arches get ordered.  Note that the exact
nevra must be the same since pkgorder is indexed by nevra instead of
just name these days.  So pkgorder needs to be run once all of the
final packages which are going to be in the tree are in there, then
genhdlist with the pkgorder file.

CC'ing Justin and I'll double check the hdlist later to verify it.
Comment 3 Justin M. Forbes 2003-12-29 16:31:24 EST
It depends on when the image was downloaded.  The initial preview
release had an error in which I did not add --fileorder to the
genhdlist.  This has been corrected, and should appear on the newest
boot.iso for preview, and work correctly on test1 when it is released.
Comment 4 Justin M. Forbes 2004-01-12 17:33:31 EST
This should be fixed in test1 when it is released.

Note You need to log in before you can comment on or make changes to this bug.