Bug 112718 - kudzu crashes with Segmentation Fault
Summary: kudzu crashes with Segmentation Fault
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-29 20:33 UTC by Sebastian Krieg
Modified: 2014-03-17 02:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 21:11:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian Krieg 2003-12-29 20:33:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
kudzu crashes with the following message:
"/etc/rc5.d/S05kudzu: line 97 /usr/sbin/kudzu $KUDZU_ARG -t 30"

This message is shown during boot process and command line input.																																																					

Version-Release number of selected component (if applicable):
kudzu-1.1.36-1

How reproducible:
Always

Steps to Reproduce:
1. Reboot the computer or
2. input the command /usr/sbin/kudzu as root at command line
    

Actual Results:  error message (description) and mouse failes (at command line)	

Expected Results:  service runs without errors

Additional info:

the packages
redhat-config-network, hwbrowser and isdn4k-utils doesn't work

Configuration:
Mainboard MSI K7T266Pro, AMD Athlon 1400MHz, 512MB RAM, ATI Radeon 9600Pro, USB PC-to-PC Controller Genelink, LG GCC-4120B CD-RW/DVD-ROM

Comment 1 Bill Nottingham 2003-12-29 22:52:09 UTC
I'm guessing it doesn't segfault if you remove the USB PC<->PC cable?

Comment 2 Sebastian Krieg 2003-12-30 21:56:52 UTC
Removing the USB PC-to-PC Controller was not an good idea: The error 
message was now "434 Segmentation fault" (before: "467") and 
X-Windows starts without Mouse (Wheel PS/2) and Keyboard. 
 

Comment 3 Sebastian Krieg 2004-01-01 22:31:29 UTC
I found a bugzilla entry #106332 with the same content in FC1-test1. 
Norm Brake (norm@nebcs.com) developed a workaround. But I can't make 
a binary, because there is an "DIET" in the makefile and my system 
doesn't know it. 

Comment 4 Sebastian Krieg 2004-01-05 16:26:38 UTC
Hi, 
 
there are some news: 
1. I found the dietlibc. Tthis problem is obsolete. 
2. After deactivation of USB-controller in the BIOS, the problem 
doens't exist anymore. The redhat-config-network works fine, I have 
internet access with kisdndock. 
 
But I havn't any USB-devices (that is no problem, I haven't any 
USB-periphery). 
 
excerpt from the manual MSI K7T266Pro (MSI-6380): 
"...USB Interface ... controlled by the VT8233 southbridge ..." 
 
I hope the netxt version of kudzu is been fixed. 

Comment 5 Michele Mazzucco 2004-01-05 22:04:11 UTC
After deactivation of UBS-controller in the BIOS kudzu works fine but
 any USB-devices doesn't work.

Comment 6 Sebastian Krieg 2004-01-06 08:25:12 UTC
I hope there are no USB-device at your PC ... 

Comment 7 Michele Mazzucco 2004-01-06 11:49:07 UTC
This is my problem. If I turn off the USB option in my BIOS I can't
use my USB mouse

Comment 8 Michele Mazzucco 2004-01-06 15:37:41 UTC
I have "downgraded" my kudzu version to kudzu-0.99.99-1 (present in
RH9 CD1):

 rpm -Uv --oldpackage --nodeps kudzu-0.99.99-1.i386.rpm

Now kudzu redhat-config-network, kisdndock and any USB device work
fine, while hwbrowser doesn't work yet.

However now there is a problem with redhat-config-xfree86 (the monitor
configuration GUI):

How to reproduce:
 input the command "redhat-config-xfree86" as root at command line

Results:
 Traceback (most recent call last):
   File "/usr/share/redhat-config-xfree86/xconf.py", line 330, in ?
     vc = rhpl.videocard.VideoCardInfo()
   File "/usr/lib/python2.2/site-packages/rhpl/videocard.py", line
504, in __init__
     vc.setPCIBus(card.pcibus)
 AttributeError: pciDevice instance has no attribute 'pcibus'

Comment 9 Sebastian Krieg 2004-01-06 19:15:02 UTC
After disabling USB in BIOS I have not installed the  
redhat-config-xfree86 again, because this kills my boot process. I  
don't need it anyway.  
If you use an binary driver (ATI or NVIDIA), you set the X-Server 
once during installation and you can edit it in the 
/etc/X11/XFree86Config-4. 
  
BTW: Yum and synaptic are better tools than redhat-config-packages.  
  
I see, We have developed some workarounds (The Linux community  
works!!!) and I hope, that there are fixed packages in next time.  

Comment 10 Bill Nottingham 2004-02-04 06:36:40 UTC
Please try the kudzu-1.1.36.1-1 packages at:
 http://people.redhat.com/notting/kudzu/

These may resolve some of your issues.

Comment 11 Sebastian Krieg 2004-02-10 20:30:57 UTC
I installed this package: Success! 
During boot process kudzu founds the contoller and the USB-devices. 
 
Thank you. 
 
Sebastian 

Comment 12 Bill Nottingham 2004-02-10 21:11:39 UTC
Cool. Closing as fixed in rawhide, update will be released for FC1 in
the near future.


Note You need to log in before you can comment on or make changes to this bug.