Bug 1127196 - RHEL OSP Installer: Password change not verified
Summary: RHEL OSP Installer: Password change not verified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: z1
: Installer
Assignee: Jiri Stransky
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 11:20 UTC by Mike Kolesnik
Modified: 2014-10-01 13:26 UTC (History)
6 users (show)

Fixed In Version: rhel-osp-installer-0.3.4-2.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Mike Kolesnik 2014-08-06 11:20:48 UTC
Description of problem:
RHEL OSP Installer lets user set password but doesn't verify it (ask for it again).
This is common practice when setting/changing password to avoid user mistakes.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Run osp-installer
2. On "Configure client authentication" choose option "3. Change Root Password"
3. Enter new password

Actual results:
Password is changed without verifying


Expected results:
Installer should ask to enter password again and check that both passwords match.


Additional info:
If there's a mismatch user should start a new and enter the password 2 times, same as with passwd command.

Comment 1 Dan Radez 2014-08-19 14:24:42 UTC
I'm going to have to pass this to Marek. I think this may be some underlying kafo development.

Comment 2 Jiri Stransky 2014-09-02 13:07:25 UTC
Pull request upstream:

https://github.com/theforeman/foreman-installer-staypuft/pull/82

In "Configure client authentication" wizard after selecting "3. Change Root Password", the installer will now ask for password and then also for password confirmation. The validation is performed at the same time as the rest of the validations, when user selects "1. Proceed with the above values". If the confirmation did not match the password, user will see an error message "Password and confirmation do not match, please re-enter the password".

Comment 3 Jiri Stransky 2014-09-03 08:05:42 UTC
Merged upstream.

Comment 6 Ami Jeain 2014-09-14 14:58:24 UTC
validation is done as soon as you hit Next on that window.

Comment 8 errata-xmlrpc 2014-10-01 13:26:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.