Bug 1127202 - RHEL OSP Installer: Password shown in separate line
Summary: RHEL OSP Installer: Password shown in separate line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: z1
: Installer
Assignee: Marek Hulan
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 11:36 UTC by Mike Kolesnik
Modified: 2014-10-01 13:26 UTC (History)
4 users (show)

Fixed In Version: rhel-osp-installer-0.3.4-2.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Mike Kolesnik 2014-08-06 11:36:38 UTC
Description of problem:
When asking to show password, it's shown on a separate line.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Run rhel-sop-installer
2. On "Configure client authentication" choose option "4. Display root password"
3.

Actual results:
Current root password: 'password'
Configure client authentication
          SSH public key: ''
           Root Password: '********'

Please set a default root password for newly provisioned machines. If you choose not to set a password, it will be generated randomly. The password must be a minimum of 8 characters. You can also set a public ssh key which will be deployed to newly provisioned machines.

How would you like to proceed?:
1. Proceed with the above values
2. Change SSH public key
3. Change Root Password
4. Display root password



Expected results:
Configure client authentication
          SSH public key: ''
           Root Password: 'password'

Please set a default root password for newly provisioned machines. If you choose not to set a password, it will be generated randomly. The password must be a minimum of 8 characters. You can also set a public ssh key which will be deployed to newly provisioned machines.

How would you like to proceed?:
1. Proceed with the above values
2. Change SSH public key
3. Change Root Password
4. Display root password


Additional info:

Comment 1 Dan Radez 2014-08-12 15:04:06 UTC
I'm going to have to get Marek to look at this. The way it's currently designed looks like it will need some work that I'm not familiar enough to do.

Comment 2 Marek Hulan 2014-08-13 13:58:03 UTC
Fix merged in https://github.com/theforeman/foreman-installer-staypuft/pull/74
I've also changed menu text to 'Toggle Root password visibility' so it makes sense even when password is being displayed

Comment 5 Ami Jeain 2014-09-16 06:42:41 UTC
verified in latest puddle

Comment 7 errata-xmlrpc 2014-10-01 13:26:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.