Bug 1127229 - Neutron cli fails to authenticate
Summary: Neutron cli fails to authenticate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 12:32 UTC by yfried
Modified: 2014-11-04 17:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:01:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description yfried 2014-08-06 12:32:56 UTC
Unable to execute neutron cli commands (other clients work fine)

Happens suddenly!

[root@maca25400702875 ~(keystone_yfried)]# neutron net-list
+--------------------------------------+---------+--------------------------------------------------+
| id                                   | name    | subnets                                          |
+--------------------------------------+---------+--------------------------------------------------+
| 2d2d5bd9-bc73-46c9-b306-217c1e1de53b | private | 7b290d35-28f1-43a3-a26e-54ed852fae4f 10.0.0.0/24 |
+--------------------------------------+---------+--------------------------------------------------+


[root@maca25400702875 ~(keystone_admin)]# neutron net-create public
Authentication required


[root@maca25400702875 ~(keystone_admin)]# nova list
+----+------+--------+------------+-------------+----------+
| ID | Name | Status | Task State | Power State | Networks |
+----+------+--------+------------+-------------+----------+
+----+------+--------+------------+-------------+----------+

[root@maca25400702875 ~(keystone_admin)]# rpm -qa | grep "neutron\|keystone"
openstack-keystone-2014.1.1-1.el7ost.noarch
openstack-neutron-ml2-2014.1.1-4.el7ost.noarch
openstack-neutron-2014.1.1-4.el7ost.noarch
python-keystoneclient-0.9.0-1.el7ost.noarch
python-keystone-2014.1.1-1.el7ost.noarch
python-neutron-2014.1.1-4.el7ost.noarch
python-neutronclient-2.3.4-2.el7ost.noarch


neutron/server.log
2014-08-06 12:27:42.680 16903 INFO neutron.wsgi [-] (16903) accepted ('10.35.163.103', 59106)
2014-08-06 12:27:42.682 16903 INFO urllib3.connectionpool [-] Starting new HTTP connection (1): 10.35.163.72
2014-08-06 12:27:42.708 16903 WARNING keystoneclient.middleware.auth_token [-] Authorization failed for token
2014-08-06 12:27:42.708 16903 INFO keystoneclient.middleware.auth_token [-] Invalid user token - rejecting request
2014-08-06 12:27:42.708 16903 INFO neutron.wsgi [-] 10.35.163.103 - - [06/Aug/2014 12:27:42] "GET /v2.0/ports.json?tenant_id=fb8f63dd01564e73a811bcd550c9e56d&device_id=f07cfe36-d404-4258-88dd-45e63aeffcbc HTTP/1.1" 401 261 0.027404



Solved by restarting neutron-server on controller

Comment 3 yfried 2014-08-13 06:06:11 UTC
staypuft version
ruby193-rubygem-staypuft-0.1.22.el6ost

Comment 5 yfried 2014-10-22 12:02:23 UTC
Hi, in order to verify this bug, we need to know what caused it and how it was solved.

Comment 6 Mike Burns 2014-10-24 13:29:19 UTC
There was no root cause found for this BZ.  The verification is to test neutron cli commands.

Comment 8 Ofer Blaut 2014-11-02 14:00:09 UTC
Tested on rhel-osp-installer-0.4.7-1.el6ost.noarch

Comment 10 errata-xmlrpc 2014-11-04 17:01:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.