Bug 1127232 - Uberfire dependency is misaligned to EAP 6.3 BOM
Summary: Uberfire dependency is misaligned to EAP 6.3 BOM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Build and Assembly
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER1
: 6.2.0
Assignee: Edson Tirelli
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 12:42 UTC by Ryan Zhang
Modified: 2015-10-20 10:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-16 19:37:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Ryan Zhang 2014-08-06 12:42:08 UTC
Description of problem:
By looking at 0.4.0.CR1, there are many dependencies misaligned to community BOM and kie-parent-with-dependencies. Then it  misaligned to EAP 6.3 too.

For example:
mvel's version.
mortbay.jetty
logback-classic 
jasypt
guava
etc etc.

The request is to make uberfire use the same dependency version as EAP 6.3.
Considering EAP 6.3 GA is not avaiable yet, it needs to align to community bom and kie-parent-with-dependencies.
By doing this, we can make sure BRMS/BPM won't have multiple version in products.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Ryan Zhang 2014-09-11 04:45:57 UTC
Hi, Jonathan
I have seen that Errai inherit the integration platform. If uberfire align with Errai BOM, it should transitively align to integraiton-bom. 
Just a few things I noticed:
1) Errai 3.1.0-SNAPSHOT currently use 6.0.0.CR9 community bom, however droolsjbpm use 6.0.0.CR11. So bpms/brms 6.1.0 require uberfire to align to 6.0.0.CR11 or new version in future.
2) Currently uberfire depends on errai 2.4.4.Final, when would uberfire depend on 3.1.x series?
3) It seems that Errai 3.1.0-SNAPSHOT needs to tidy up the dependency in the errai-bom . There are some dependency misalignment to integration-bom. But this probably needs a Bugzilla to raise against on Errai.

(In reply to Jonathan Fuerth from comment #3)
> Hi Edson,
> 
> This is already one of the things on my to-do list. Specifically, we're
> planning to align with the Errai BOM, because UberFire is built on Errai and
> it should ideally align with all Errai dependencies. But this should
> transitively get what you're asking for, since the Errai BOM inherits from
> the platform integration BOM:
> 
> https://github.com/errai/errai/blob/master/errai-bom/pom.xml
> 
> PS: do these comments really need to be marked private?

Comment 5 Jonathan Fuerth 2014-09-15 14:00:51 UTC
Hi Ryan,

Thanks for the analysis!

To answer question 2:

BxMS 6 currently depends on UberFire 0.4.[latest]. However, work is underway in the community projects to update to UberFire 0.5.[latest].

UberFire 0.4 depends on Errai 2.4.[latest], and the Errai 2.4 BOM depends on jboss-parent, not platform-integration-parent. Errai 2.4 is a maintenance branch at this point, only getting high priority patches. I expect a major BOM update to this version of Errai wouldn't be appropriate at this point.

UberFire 0.5 depends on Errai 3.0.[latest], and this BOM also depends on jboss-parent.

UberFire 0.6 will depend on Errai 3.1, but UberFire 0.6 doesn't exist yet, so it's much too early to say when we could expect BxMS to switch to UF 0.6.

Given the above, I'm thinking it would be best to connect the UberFire 0.4 and 0.5 BOMs directly to the platform integration BOM, and wait for UF 0.6 + Errai 3.1 to connect the UF BOM to the Errai BOM. What do you think?

As for points 1 and 2, these issues should be easy to solve with a couple of pull requests to Errai 3.1.

Comment 6 Ryan Zhang 2014-09-16 02:36:47 UTC
(In reply to Jonathan Fuerth from comment #5)
> Hi Ryan,
> 
> Thanks for the analysis!
> 
> To answer question 2:
> 
> BxMS 6 currently depends on UberFire 0.4.[latest]. However, work is underway
> in the community projects to update to UberFire 0.5.[latest].
> 
> UberFire 0.4 depends on Errai 2.4.[latest], and the Errai 2.4 BOM depends on
> jboss-parent, not platform-integration-parent. Errai 2.4 is a maintenance
> branch at this point, only getting high priority patches. I expect a major
> BOM update to this version of Errai wouldn't be appropriate at this point.
> 
> UberFire 0.5 depends on Errai 3.0.[latest], and this BOM also depends on
> jboss-parent.
> 
> UberFire 0.6 will depend on Errai 3.1, but UberFire 0.6 doesn't exist yet,
> so it's much too early to say when we could expect BxMS to switch to UF 0.6.
> 
> Given the above, I'm thinking it would be best to connect the UberFire 0.4
> and 0.5 BOMs directly to the platform integration BOM, and wait for UF 0.6 +
> Errai 3.1 to connect the UF BOM to the Errai BOM. What do you think?
That sounds very good to me.
> 
> As for points 1 and 2, these issues should be easy to solve with a couple of
> pull requests to Errai 3.1.
Yes, Agreed!

Thanks!

Comment 10 Ryan Zhang 2015-07-28 11:31:17 UTC
I will put the unmatch list here if any mistach happens after I upgrade the alginment  EAP 6.4.2.

Set the target release on ER1


Note You need to log in before you can comment on or make changes to this bug.