Bug 1127266 - Problems with tokengroups and ldap_group_search_base
Summary: Problems with tokengroups and ldap_group_search_base
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.1
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On: 1127265
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 13:45 UTC by Jakub Hrozek
Modified: 2019-04-16 14:15 UTC (History)
10 users (show)

Fixed In Version: sssd-1.12.1-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: When a non-standard group search base was used, the ID provider might be restricted so that it doesn't allow to resolve all group GIDs returned by the tokenGroups attribute during initgroups call. Consequence: The admin restricted the search base in order to only see certain groups in the 'id output' However, all group GIDs would be reported, with those outside the group base available only as numerical GIDs, not group names. Fix: We documented that if restricting the group search base, tokengroups support must be disabled manually. Result: With disabled tokengroups support and restricted group search base, only the groups in the restricted group search base are visible and all the GIDs resolve into group names.
Clone Of: 1127265
Environment:
Last Closed: 2015-03-05 10:33:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0441 normal SHIPPED_LIVE sssd bug fix and enhancement update 2015-03-05 15:05:27 UTC

Description Jakub Hrozek 2014-08-06 13:45:33 UTC
+++ This bug was initially created as a clone of Bug #1127265 +++

This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2389

When I enable ldap_group_search_base to restrict to a subset of all groups with tokengroups enabled, it breaks spectacularly.  Disable tokengroups, and it works or disable ldap_group_search_base and it works.

{{{
# service sssd stop;rm -f /var/lib/sss/{db,mc}/* /var/log/sssd/*;sleep 3;service sssd start;sleep 3;id user;id user;service sssd stop
Redirecting to /bin/systemctl stop  sssd.service
Redirecting to /bin/systemctl start  sssd.service
uid=12345(user) gid=513(Domain Users) groups=513(Domain Users)
id: user: no such user
}}}

Log includes:

{{{
[sdap_get_initgr_done] (0x4000): Initgroups done
[sdap_get_initgr_done] (0x4000): Error in initgroups: [2][No such file or directory]
}}}

Tested on git/master dfef1d050c35398c6061256a947b4cc9c1f4b8e6

--- Additional comment from Jakub Hrozek on 2014-08-06 09:42:07 EDT ---

This is a user-visible regression.

Comment 3 Jakub Hrozek 2014-08-19 14:37:44 UTC
This was fixed in master some time ago:
    master: 983983dd1629ab33eab340a40d9ee83965a339c6
    sssd-1-11: 6e6c099b02014d6e2ed97a057c6c521db9c30139

Comment 5 Kaushik Banerjee 2014-12-03 11:21:22 UTC
Verified with 1.12.2-28.el7

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: bug_automation_007: Problems with tokengroups and ldap_group_search_base
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Command 'id testuser05-817192@sssdad2012.com' (Expected 0, got 0)
:: [   PASS   ] :: File '/var/log/sssd/sssd_sssdad2012.com.log' should not contain 'No ID ctx available for \[sssdad2012.com\]' 
:: [   LOG    ] :: Duration: 5s
:: [   LOG    ] :: Assertions: 2 good, 0 bad
:: [   PASS   ] :: RESULT: bug_automation_007: Problems with tokengroups and ldap_group_search_base

Comment 19 errata-xmlrpc 2015-03-05 10:33:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0441.html


Note You need to log in before you can comment on or make changes to this bug.