Bug 1127271 - When replying to a message, newlines are doubled
Summary: When replying to a message, newlines are doubled
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 13:54 UTC by kubrick@fgv6.net
Modified: 2015-12-02 16:11 UTC (History)
6 users (show)

Fixed In Version: evolution-3.13.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 03:21:37 UTC


Attachments (Terms of Use)
example message (9.63 KB, text/plain)
2014-09-05 10:55 UTC, kubrick@fgv6.net
no flags Details

Description kubrick@fgv6.net 2014-08-06 13:54:30 UTC
Description of problem:
In Evolution, when replying to a message, the quoted text has all its newlines doubled.

Version-Release number of selected component (if applicable):
3.10.4

How reproducible:
Always.

Comment 1 Milan Crha 2014-09-01 11:56:48 UTC
Thanks for a bug report. i tried to reproduce this, but no luck, the new lines are not doubled in a newly created message reply either on a HTML or a plain text message. I suppose this is message dependant; could you provide a test message on which this can be reproduced, please? I recall a similar issue, but only in a way that it existed in some way, I do not recall its resolution or where it was filled - it's possible it was just a user claim on some mailing list or an IRC channel.

Comment 2 kubrick@fgv6.net 2014-09-01 12:51:34 UTC
It's specifically HTML messages sent from outlook.

Comment 3 Fedora Admin XMLRPC Client 2014-09-04 14:30:41 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 kubrick@fgv6.net 2014-09-05 10:55:24 UTC
Created attachment 934744 [details]
example message

Comment 5 Milan Crha 2014-09-08 08:28:52 UTC
Thanks for the update. I tried this with just released 3.12.6, which is using gtkhml3 as its composer component and I can reproduce the issue there. I also tried this with recent development version, couple commits after 3.13.5, and the issue is fixed there. The 3.13.5 is using webkit-based composer.

I'm closing this, but I'd also like  to ask Tomas Popela to retest with your test message once a port to webkit2 will be done, just to ensure that nothing broke here by the port.

Comment 6 kubrick@fgv6.net 2014-10-16 17:42:03 UTC
F21 is using 3.12, still using gtkhtml3, and this is a really annoying bug (actually reputation impacting for Linux in my company).

I'm reassigning the bug to gtkhtml3.

Comment 7 Fedora End Of Life 2015-11-04 15:02:00 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2015-12-02 03:21:41 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.