Bug 11273 - anaconda dies during upgrade when /tmp is symlink to /var/tmp
Summary: anaconda dies during upgrade when /tmp is symlink to /var/tmp
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-07 07:24 UTC by doane
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-10 19:35:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description doane 2000-05-07 07:24:51 UTC
During an upgrade from 6.1 to 6.2, where /tmp is a symbolic link to
/var/tmp, I get the following message just after I have told it I do not
wish to make any changes to the packages it will install (below text is
copied by hand so there may be some minor errors):

-Exception Occurred-

Traceback (innermost last):
File "/usr/bin/anaconda", line 342 in ? intf.run(todo, test=test)
File "/usr/lib/anaconda/text.py", line 1165 in run rc = apply(step[1](),
step[2])
File "/usr/lib/anaconda/text.py", line 702 in __call__ if todo.doInstall():
File "/tmp/updates/todo.py", line 1163 in do Install()
  self.instLog = open(setl.instPath _ logname, "w+")
IOError: [Errno2] No such file or directory:
'/mnt/sysimage/tmp/upgrade.log'

One solution is to remove the symlink and create a /tmp directory on the /
file system.

It might be nice, however, for anaconda to notice this problem before it
tries to write stuff into that "directory".

I know, I know: "Doctor, doctor, it hurts when I do this", etc.  I think
that such a symlink is common, however.  For me, it prevents / from filling
up when certain lame apps and installers write megabytes to /tmp.

Comment 1 Jay Turner 2000-05-10 19:35:59 UTC
The installer is not able to deal with absolute links on the filesystem and this
is the cause of the problem you are seeing.  Change the link from absolute to
relative and the upgrade will go without any problems.


Note You need to log in before you can comment on or make changes to this bug.