Bug 1127302 - staypuft: can't remove a deployment that has hosts assigned
Summary: staypuft: can't remove a deployment that has hosts assigned
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 15:06 UTC by Dafna Ron
Modified: 2014-12-15 09:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 18:13:54 UTC


Attachments (Terms of Use)
screen shot (108.87 KB, image/png)
2014-08-06 15:06 UTC, Dafna Ron
no flags Details

Description Dafna Ron 2014-08-06 15:06:25 UTC
Created attachment 924516 [details]
screen shot

Description of problem:

when I try to remove a deployment which has hosts assigned to it I get an error: 

Cannot delete record because it has descendants.

I think that this looks really bad from user prospective and we should be able to remove the hosts from the deployment when the user approves it. 
which is why I think we need to add a pop-up with a warning + approve/cancel operation. 

Version-Release number of selected component (if applicable):

ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a new deployment and assign hosts to the deployment
2. try to remove the deployment 
3.

Actual results:

we get this error: 
Cannot delete record because it has descendants.

Expected results:

1. this looks like a UI crash 
2. we should be able to complete this action with user approval (detaching the hosts from the deployment ourselves) 

Additional info: look at screen shot - not very user friendly and looks like crash. 

Ancestry::AncestryException
Cannot delete record because it has descendants.
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

Comment 3 Alexander Chuzhoy 2014-10-31 14:22:16 UTC
Verified:

rhel-osp-installer-0.4.6-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.12-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.32-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch



Was able to remove the deployment after assinging hosts to it.

Comment 4 Scott Lewis 2014-11-04 18:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.