Bug 1127309 - rdopkg version 0.18 fails to find rdoupdate.bsources.koji_
Summary: rdopkg version 0.18 fails to find rdoupdate.bsources.koji_
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: rdopkg
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Jakub Ruzicka
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 15:27 UTC by Ryan Brown
Modified: 2015-06-29 18:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 18:43:25 UTC


Attachments (Terms of Use)

Description Ryan Brown 2014-08-06 15:27:07 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install rdopkg-0.18-1.fc20.noarch
2. Run "rdopkg --version"

Actual results:
Traceback (most recent call last):
  File "/usr/bin/rdopkg", line 9, in <module>
    load_entry_point('rdopkg==0.18', 'console_scripts', 'rdopkg')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 357, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2394, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2108, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.7/site-packages/rdopkg/shell.py", line 10, in <module>
    import core
  File "/usr/lib/python2.7/site-packages/rdopkg/core.py", line 7, in <module>
    import actions
  File "/usr/lib/python2.7/site-packages/rdopkg/actions.py", line 4, in <module>
    import rdoupdate.core
  File "/usr/lib/python2.7/site-packages/rdoupdate/core.py", line 12, in <module>
    import plug
  File "/usr/lib/python2.7/site-packages/rdoupdate/plug.py", line 35, in <module>
    import_fetchers()
  File "/usr/lib/python2.7/site-packages/rdoupdate/plug.py", line 32, in import_fetchers
    import_pyfiles(bsrc_dir)
  File "/usr/lib/python2.7/site-packages/rdoupdate/plug.py", line 23, in import_pyfiles
    m = import_file(pyfile)
  File "/usr/lib/python2.7/site-packages/rdoupdate/plug.py", line 14, in import_file
    return imp.load_module(name, file, filename, data)
  File "/usr/lib/python2.7/site-packages/rdoupdate/bsources/brew.py", line 1, in <module>
    from rdoupdate.bsources.koji_ import KojiSource
ImportError: No module named koji_


Expected results:
Output of version

Additional info:

Comment 1 Ben Nemec 2014-08-08 21:04:12 UTC
Looks like just a typo.  I worked around it by symlinking /usr/lib/python2.7/site-packages/rdoupdate/bsources/_koji.py to /usr/lib/python2.7/site-packages/rdoupdate/bsources/koji_.py

Comment 2 Jakub Ruzicka 2014-09-01 14:07:02 UTC
I have no idea how this happend, but there are two python-rdoupdate-0.11 builds in the wild, one with bad module name.

I updated python-rdoupdate to 0.12 to fix this problem, just `yum update python-rdoupdate`.

Sorry!


Note You need to log in before you can comment on or make changes to this bug.