Bug 1127345 - Errors/warnings logged when updating host information
Summary: Errors/warnings logged when updating host information
Keywords:
Status: CLOSED DUPLICATE of bug 1062438
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Eli Mesika
QA Contact:
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 17:15 UTC by wdaniel
Modified: 2019-04-28 09:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 07:40:52 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description wdaniel 2014-08-06 17:15:44 UTC
Description of problem:

This was originally noticed as a result of attaching a host to a different cluster using the rhevm-shell.

When the host's information is updated (changing clusters), the engine log shows RHEV's logic as it removes the host from one cluster, and adds it to a new one. During this time there are numerous errors and warning logged because certain values are in flux while the host's information is being updated. These warnings appear to be misleading since there is not actually an error at that time.

Version-Release number of selected component (if applicable):

RHEV-M 3.3.4

How reproducible:

Happens consistently in a large 3.3.4 environment

Steps to Reproduce:
1. Via API or Admin Portal put a host into maintenance mode
2. Change the cluster that the host belongs to
3. See the engine logging errors while the VM's information is updated

Actual results:

Misleading warnings/errors logged

Expected results:

Fewer messages being logged while host information is updated
Additional info:

Comment 4 Oved Ourfali 2014-08-11 07:40:52 UTC
This issue was fixed as part of fixing Bug #1062438, which was fixed in 3.4.0.
Closing as DUPLICATE.

*** This bug has been marked as a duplicate of bug 1062438 ***


Note You need to log in before you can comment on or make changes to this bug.