Bug 1127377 - WARN [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1)
Summary: WARN [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER03
: JON 3.3.0
Assignee: Lukas Krejci
QA Contact: Filip Brychta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 18:50 UTC by Matt Mahoney
Modified: 2014-12-11 14:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:05:12 UTC
Type: Bug


Attachments (Terms of Use)
server.log (1.43 MB, text/plain)
2014-08-06 18:50 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-06 18:50:46 UTC
Created attachment 924568 [details]
server.log

Description of problem:

Warnings in server.log file after clean install and server start.

13:55:11,922 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10613, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:11,985 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10643, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:12,272 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10690, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:12,291 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10745, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:12,310 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10768, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:12,327 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10787, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:12,344 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10793, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]
13:55:12,362 WARN  [org.rhq.enterprise.server.measurement.AvailabilityManagerBean] (http-/0.0.0.0:7080-1) Resource [Resource[id=10874, uuid=null, type=<null>, key=null, name=null, parent=<null>]] has multiple availabilities without an endtime - will attempt to remove the extra ones
AV:[mm-jon33dr01-t3.bc.jonqe.lab.eng.bos.redhat.com][864][full]


Version-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:

Steps to Reproduce:
1. Install and start JON
2.
3.

Actual results:
Warnings in server.log after clean install/start.

Expected results:
Should be zero silent Warnings in server.log


Additional info:

Comment 1 Heiko W. Rupp 2014-08-26 12:21:06 UTC
This is an issue that is present since the old JON 2 days.

This is certainly nothing that would show up in a clean fresh install of JON,
but needs additional conditions like an agent that has an inventory already and which was forcibly killed.
And/or a previous install which already has inventory data.

Comment 2 Lukas Krejci 2014-09-05 11:34:02 UTC
master:
commit 650cc3ca4ce2aafbafb08cdcc3eafd7c4acf77e1
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Fri Sep 5 13:31:13 2014 +0200

    [BZ 1127377] Log the recoverable error condition at DEBUG rather than WARN

release/jon3.3.x:
commit ad875c2c6ebfb8d635e917ec7411fa5716eb4552
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Fri Sep 5 13:31:13 2014 +0200

    [BZ 1127377] Log the recoverable error condition at DEBUG rather than WARN
    
    (cherry picked from commit 650cc3ca4ce2aafbafb08cdcc3eafd7c4acf77e1)
    Signed-off-by: Lukas Krejci <lkrejci@redhat.com>

Comment 3 Simeon Pinder 2014-09-17 02:49:39 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149

Comment 4 Filip Brychta 2014-09-18 12:00:45 UTC
Verified on
Version :	
3.3.0.ER03
Build Number :	
4aefe39:44e33a4


Note You need to log in before you can comment on or make changes to this bug.