Bug 1127382 - Unable to list puppet-modules since product options are missing
Summary: Unable to list puppet-modules since product options are missing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer   
(Show other bugs)
Version: 6.0.3
Hardware: Unspecified Unspecified
unspecified
medium vote
Target Milestone: 6.1
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 19:22 UTC by sthirugn@redhat.com
Modified: 2018-12-06 20:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC
Foreman Issue Tracker 10410 None None None 2016-04-22 14:58 UTC

Description sthirugn@redhat.com 2014-08-06 19:22:31 UTC
Description of problem:
Unable to list puppet-modules since product options are missing

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to list puppet-modules of an Organization
hammer> puppet-module list --organization-id=3
Error: Missing options to search product

2. I am asked to enter product search options but the production options are not present in puppet-module list --help (see below)
hammer> puppet-module list --help
Usage:
     puppet-module list [OPTIONS]

Options:
    --content-view CONTENT_VIEW_NAME Content view name to search by
    --content-view-id CONTENT_VIEW_ID content view numeric identifier
    --lifecycle-environment LIFECYCLE_ENVIRONMENT_NAME Name to search by
    --lifecycle-environment-id LIFECYCLE_ENVIRONMENT_ID  
    --organization ORGANIZATION_NAME Organization name to search by
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL Organization label to search by
    --repository REPOSITORY_NAME  Repository name to search by
    --repository-id REPOSITORY_ID repository ID
    -h, --help                    print help

Actual results:
As explained above

Expected results:
As explained above

Additional info:

Comment 1 sthirugn@redhat.com 2014-08-06 19:23:13 UTC
Version Tested:
Satellite-6.0.4-RHEL-6-20140730.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.34-1.el6sat.noarch
* foreman-compute-1.6.0.34-1.el6sat.noarch
* foreman-gce-1.6.0.34-1.el6sat.noarch
* foreman-libvirt-1.6.0.34-1.el6sat.noarch
* foreman-ovirt-1.6.0.34-1.el6sat.noarch
* foreman-postgresql-1.6.0.34-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.34-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 2 sthirugn@redhat.com 2014-08-06 19:31:19 UTC
same with info command:

hammer> puppet-module info 
Error: Missing options to search product

hammer> puppet-module info --help
Usage:
     puppet-module info [OPTIONS]

Options:
    --id ID                       puppet module identifier
    --name NAME                   Name to search by
    --organization ORGANIZATION_NAME Organization name to search by
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL Organization label to search by
    --repository REPOSITORY_NAME  Repository name to search by
    --repository-id REPOSITORY_ID repository ID
    -h, --help                    print help

Comment 4 sthirugn@redhat.com 2014-08-06 20:08:25 UTC
This has a UI workaround - Content Search -> Puppet Modules.

Comment 5 Stephen Benjamin 2015-05-07 12:15:24 UTC
Created redmine issue http://projects.theforeman.org/issues/10410 from this bug

Comment 6 Stephen Benjamin 2015-05-12 11:00:36 UTC
This totally breaks automation, can it be at least 6.1.z?

Comment 7 Brad Buckingham 2015-08-19 20:31:36 UTC
I ran a test on my Satellite 6.1.1 install and I am able to list the puppet modules without specifying a product:

hammer> puppet-module list --organization-id 1
[Foreman] Username: admin
[Foreman] Password for admin: 
-------------------------------------|-------|---------|--------
ID                                   | NAME  | AUTHOR  | VERSION
-------------------------------------|-------|---------|--------
90fb607d-8682-4e8f-87cd-f6ee176cbc08 | ovirt | jcannon | 0.0.4  
-------------------------------------|-------|---------|--------
hammer>

Comment 8 Brad Buckingham 2015-08-19 20:33:07 UTC
Hi Suresh,  Can you do me a favor and see if you are still observing this issue on 6.1.1? Thanks!

Comment 9 sthirugn@redhat.com 2015-08-31 15:47:03 UTC
Verified in Sat 6.1.2 z-stream build.  It works fine now.

hammer> puppet-module list --organization-id=17
-------------------------------------|------|------------|--------
ID                                   | NAME | AUTHOR     | VERSION
-------------------------------------|------|------------|--------
6559345f-ef5d-45f1-802a-83fdcb519d7b | motd | jeffmccune | 1.0.3  
-------------------------------------|------|------------|--------

hammer> puppet-module info --id=6559345f-ef5d-45f1-802a-83fdcb519d7b
ID:             6559345f-ef5d-45f1-802a-83fdcb519d7b
Name:           motd
Version:        1.0.3
Author:         jeffmccune
Summary:        Manages the message of the day
Description:    Places information about the host in the message of the day.
License:        Apache
Project Page:   https://github.com/jeffmccune/jeffmccune-motd
Source:         puppetlabs-motd
Dependencies:   

File checksums: 
    62755946ffc0f1321cb3096554774a58  templates/motd.erb
    a600ded995d948e393fbe2320ba8e51c  spec/spec.opts
    e52668944ee6af2fb5d5b9e798342645  spec/unit/puppet/provider/README.markdown
    3dab843b1c6d3352efe33d4140ddbd51  CHANGELOG
    bd7f0f1dadd573240cae3a354edace25  README.markdown
    ca19ec4f451ebc7fdb035b52eae6e909  spec/spec_helper.rb
    aada0a1952329e46b98695349dba6203  templates/README.markdown
    5086992bfbe4109aef08a6dc91736250  tests/init.pp
    fa064f18171fb87bd5ad1dd323dad548  Modulefile
    d34d0b70aba36510fbc2df4e667479ef  metadata.json
    3d44458cc68d8513b51e3b56c604eec4  files/README.markdown
    723e06ebe37b8c9dd1c41f218361b272  manifests/init.pp
    b9970454391883e36b55137328792a55  manifests/README.markdown
    32a1fc0121c28aff554ef5d422b8b51e  spec/README.markdown
    de26a7643813abd6c2e7e28071b1ef94  spec/unit/puppet/type/README.markdown
Tag List:       
Repositories:   
 1) Id:   177
    Name: puppetrepo1

Comment 11 errata-xmlrpc 2015-10-15 18:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.