Bug 1127386 - ERROR [ClientCommandSenderTask Timer Thread #12] (enterprise.communications.command.client.JBossRemotingRemoteCommunicator) [NEEDINFO]
Summary: ERROR [ClientCommandSenderTask Timer Thread #12] (enterprise.communications.c...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Agent
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
: 1127383 1127387 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 19:26 UTC by Matt Mahoney
Modified: 2014-09-03 18:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-03 18:30:13 UTC
Type: Bug
hrupp: needinfo? (mmahoney)


Attachments (Terms of Use)
agent.log (465.70 KB, text/plain)
2014-08-06 19:26 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-06 19:26:43 UTC
Created attachment 924579 [details]
agent.log

Description of problem:
Error in agent.log file after clean install and server start.

ERROR [ClientCommandSenderTask Timer Thread #12] (enterprise.communications.command.client.JBossRemotingRemoteCommunicator)- {JBossRemotingRemoteCommunicator.init-callback-failed}The initialize callback has failed. It will be tried again. Cause: org.jboss.remoting.CannotConnectException:Can not connect http client invoker after 1 attempt(s) -> java.net.ConnectException:Connection refused. Cause: org.jboss.remoting.CannotConnectException: Can not connect http client invoker after 1 attempt(s)

Version-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1. Install and start JON
2.
3.

Actual results:
Errors in agent.log after clean install/start.

Expected results:
Should be zero silent Errors in server.log


Additional info:

Comment 1 Heiko W. Rupp 2014-08-26 11:24:13 UTC
*** Bug 1127387 has been marked as a duplicate of this bug. ***

Comment 2 Heiko W. Rupp 2014-08-26 11:25:36 UTC
Looks like there was no server available to connect to:

Can not connect http client invoker after 1 attempt(s) -> java.net.ConnectException:Connection refused

If we should not display that error, how should the user ever find out that there is a problem?

Comment 3 Heiko W. Rupp 2014-08-26 11:28:29 UTC
*** Bug 1127383 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.