Bug 1127389 - ERROR [main] (org.rhq.enterprise.agent.AgentMain)- {AgentMain.plugin-update-failure}Failed to update the plugins
Summary: ERROR [main] (org.rhq.enterprise.agent.AgentMain)- {AgentMain.plugin-update-f...
Keywords:
Status: CLOSED DUPLICATE of bug 1127414
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Agent
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 19:32 UTC by Matt Mahoney
Modified: 2014-08-26 12:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-26 12:16:51 UTC
Type: Bug


Attachments (Terms of Use)
agent.log (465.70 KB, text/plain)
2014-08-06 19:32 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-06 19:32:16 UTC
Created attachment 924582 [details]
agent.log

Description of problem:
Error in agent.log file after clean install and server start.

ERROR [main] (org.rhq.enterprise.agent.AgentMain)- {AgentMain.plugin-update-failure}Failed to update the plugins.. Cause: java.lang.IllegalStateException: The sender object is currently not sending commands now. Command not sent: [Command: type=[remotepojo]; cmd-in-response=[false]; config=[{rhq.send-throttle=true}]; params=[{invocation=NameBasedInvocation[getLatestPlugins], targetInterfaceName=org.rhq.core.clientapi.server.core.CoreServerService}]]


Version-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1. Install and start JON
2.
3.

Actual results:
Errors in agent.log after clean install/start.

Expected results:
Should be zero silent Errors in

Additional info:

Comment 1 Heiko W. Rupp 2014-08-26 12:16:51 UTC
Followup error of Bug 1127414

Plugins can not be updated if no server is reachable.

*** This bug has been marked as a duplicate of bug 1127414 ***


Note You need to log in before you can comment on or make changes to this bug.