Bug 1127410 - WARN [ResourceDiscoveryComponent.invoker.daemon-10] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable
Summary: WARN [ResourceDiscoveryComponent.invoker.daemon-10] (org.rhq.plugins.postgre...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Agent
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER02
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 20:19 UTC by Matt Mahoney
Modified: 2014-12-11 14:03 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:03:17 UTC


Attachments (Terms of Use)
agent.log (465.70 KB, text/plain)
2014-08-06 20:19 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-06 20:19:18 UTC
Created attachment 924590 [details]
agent.log

Description of problem:

Warning in agent.log file after clean install and server start.

WARN  [ResourceDiscoveryComponent.invoker.daemon-10] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-12] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-13] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-15] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-18] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-1] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-21] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-22] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-24] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-2] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-3] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-5] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-7] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.
WARN  [ResourceDiscoveryComponent.invoker.daemon-9] (org.rhq.plugins.postgres.PostgresDiscoveryComponent)- PostgreSQL data directory (/var/lib/pgsql/data) does not exist or is not readable. Make sure the user the RHQ Agent is running as has read permissions on the directory and its parent directory.


Version-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1. Install and start JON.
2.
3.

Actual results:
Warnings in agent.log after clean install/start.

Expected results:
Should be zero silent Warnings in server.log

Additional info:

Comment 1 Thomas Segismont 2014-08-22 17:08:15 UTC
This warning won't go away, it's the way to indicate the users that we cannot edit the config file because of file perms. But we can certainly make the agent log it only once.

Comment 2 Thomas Segismont 2014-08-25 20:41:11 UTC
Fixed in master

commit c2b6f256d0f045e8cdb741e78e3c79254c203af8
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon Aug 25 22:38:17 2014 +0200

Log at debug level in discovery code (which is called often)
Log problems with the config file only once when the resource component is started

Also, some code cleanup

Comment 3 Jay Shaughnessy 2014-08-26 14:22:28 UTC
release/jon3.3.x commit 70628464957ba4a4aed04353fa2abf6bde7899e7
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon Aug 25 22:38:17 2014 +0200

    (cherry picked from commit c2b6f256d0f045e8cdb741e78e3c79254c203af8)

    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 4 Simeon Pinder 2014-09-03 20:31:52 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194


Note You need to log in before you can comment on or make changes to this bug.