Bug 1127423 - [RFE] Need OSP installer to be able to support removing compute nodes
Summary: [RFE] Need OSP installer to be able to support removing compute nodes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: Installer
Assignee: Jason Guiditta
QA Contact: yeylon@redhat.com
URL: https://trello.com/c/IZpOPLD2/146-cru...
Whiteboard:
Depends On: 1123157
Blocks: 1163445 1198799
TreeView+ depends on / blocked
 
Reported: 2014-08-06 20:45 UTC by Perry Myers
Modified: 2016-04-26 14:49 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1123157
Environment:
Last Closed: 2016-04-04 15:05:16 UTC


Attachments (Terms of Use)

Description Perry Myers 2014-08-06 20:45:44 UTC
+++ This bug was initially created as a clone of Bug #1123157 +++

Description of problem:
This is to allow installer to add a node to a compute group. This includes installing operating system, an extra libraries needed for ceph storage, all networks setup. (For the future extra Ceph keyring file if ceph is one of storage block back-ends for ephemeral storage and/or VM live migration).

For node deletion, VM migration is NOT part of this RFE. It is assumed that when a compute node is removed it does not have any user VMs or containers on it. But specifying in OSP installer that node is removed, or removed automatically after some administrator specified timeout, cleanup of OpenStack database, and OSP installer one are part of RFE.

For node replacement, Installer should provide a way to specify which node in compute cluster should be replaced, it could be down already, or still active.
But new node should attain identity of replaced node, including its network connections and its IP addresses. For this RFE assume that there no user VMs or containers on the node. (for the future we should add RFE for replacing that have user VMs or containers). Start with KVM hypervisor first. 

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from RHEL Product and Program Management on 2014-07-24 23:32:41 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Mike Burns on 2014-07-25 09:38:30 EDT ---



--- Additional comment from Scott Lewis on 2014-08-05 08:56:12 EDT ---

changing flag for RHEL-OSP Installer bug

--- Additional comment from Perry Myers on 2014-08-06 16:45:01 EDT ---

We need to treat adding and removing compute nodes as separate bugs because the work involved with each is different.  This bug will track adding new compute nodes.  It will be cloned to a different bug for removing.

Also, replacement == remove + add, so we don't need to track anything special for replacement.

Comment 4 Jason Guiditta 2016-04-04 15:05:16 UTC
we are no longer implementing new features for ofi (and is handled already in ospd)


Note You need to log in before you can comment on or make changes to this bug.