Bug 1127461 - Rubygem-Staypuft: HA-neutron deployment fails - the corosync.conf has a nodelist consisting of IP addresses from different subnets.
Summary: Rubygem-Staypuft: HA-neutron deployment fails - the corosync.conf has a node...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: ga
: Installer
Assignee: Scott Seago
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 22:30 UTC by Alexander Chuzhoy
Modified: 2014-08-21 18:08 UTC (History)
5 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:08:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Alexander Chuzhoy 2014-08-06 22:30:46 UTC
Rubygem-Staypuft:  HA-neutron deployment fails - the corosync.conf has a nodelist consisting of IP addresses from different subnets.


Environment:
rhel-osp-installer-0.1.6-5.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-19.9.el6ost.noarch


Steps to reproduce:
1. Install rhel-osp-installer
2. Create/run an HA neutron deployment with 2 computes.

Result:
The deployment gets stuck on installing the controllers - 60%.
Running "pcs cluster status" on different nodes shows that there are 2 clusters:
A: consisting of 2 nodes
B: consisting of 1 node.
The corosync.conf has a nodelist consisting of IP addresses from 2 different subnets. Cluster "A" nodes IPs from one subnet, and cluster "B" uses the IP taken from another NIC- different subnet.


Expected:
Deployment should complete with no issues.

Comment 4 Alexander Chuzhoy 2014-08-11 20:41:53 UTC
Verified: rhel-osp-installer-0.1.9-1.el6ost.noarch


This particular issue doesn't reproduce now.

Comment 6 errata-xmlrpc 2014-08-21 18:08:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.