Bug 112754 - arjanv's 2.6 network problems
arjanv's 2.6 network problems
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-12-30 11:47 EST by Rob Terhaar
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-19 11:05:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rob Terhaar 2003-12-30 11:47:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
Formatted my hard drive. Installed fedora core 1. Installed apt and 
added arjanv's 2.6 apt source to my sources list. Installed 2.6 bin 
and source. Once booted into 2.6, i'm able to do functions like ping 
and dig successfully. Samba and NTP are also working. 

The problem is that I am unable to use programs like mozilla, gaim, 
lynx. The programs preform the dns lookup successfully, then just 
sits there while trying to connect. 

I've tried compileing the network drivers into the kernel, toggleing 
preempting, and turning off all firewall/filtering options. I've also 
tried running these programs root and normal user, and have tried 3 
diffrent network cards. (2 3com 3c509's and one intel 82557) When i 
boot back to 2.4, everything works correctly.

Version-Release number of selected component (if applicable):
kernel 2.6.0-1.107

How reproducible:

Steps to Reproduce:
1.install fedora core 1 on a dell xps t700r
2.install arjanv's 2.6 kernel
3.try running mozilla/lynx

Actual Results:  Programs like mozilla/gaim/evolution can't get out 
to the internet.

Expected Results:  Programs in question should work the same way as 
in 2.4 kernel

Additional info:

Let me know if you need my kernel .configs or any stack trace logs 
from mozilla.
Comment 1 Arjan van de Ven 2003-12-30 11:49:48 EST
is it with all websites or only some?
my kernel has ECN enabled which is a TCP/IP performance feature but
some firewalls on the internet incorrectly block it...
(you can turn it off by doing echo 0 > /proc/sys/net/ipv4/tcp_ecn )

If this is the case then the owners of said firewalls need to upgrade
the firmware on it; at least on cisco the "broken" firmwares all had
security issues that were fixed since.
Comment 2 Rob Terhaar 2003-12-30 12:20:29 EST
Bingo! Turning off ECN fixed the problem. I'm using a Netgear fvs318 
NAT router with the latest firmware (firmware 2.1, as of oct30th 
2003). It wasn't only blocking websites, it was effecting gaim and 
evolution too. 

Thank you, your work is greatly appreciated!!!

Note You need to log in before you can comment on or make changes to this bug.