Bug 112756 - PNP missing in 2.6 kernel
PNP missing in 2.6 kernel
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
All Linux
high Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-12-30 12:06 EST by Thomas Dodd
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-26 00:23:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas Dodd 2003-12-30 12:06:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6b)

Description of problem:
The ISA PNP tools have been replaced with in kernel code, but that
code is not enabled in the current kernel builds. This is needed for
many ISA card to work.

In my case it's a PCMCIA socket. Vadem VG-469 ISA-to-PCMCIA, using the
i82365 driver. Enabling ISA-PNP in the kerenbl config allows it to work.
I'm currently using this options:

The DEBUG option is probably not needed.
I also noticed most/all of the ALSA ISA sound cards are not
configured. Many/most of them would use the PNP options too. The OSS
version are on.

Is there any particular reason not to include ISA PNP?
What about the ALSA drivers for ISA cards?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot a 2.6 kernel from people.redhat.com/arjanv/2.5
2. PCMCIA fails to start
3. no PCMCIA devices can be used

Actual Results:  
PCMCIA is not avaliable because the ISA-PCMCIA adapter is not
configured. This is an add-in card, and BIOS won't configure it

Expected Results:  The kernel level ISAPNP driver should configure the
adapter, the PCMCIA starts and cdevices can be used.

Additional info:

Rebilding the kernel with ISAPNP and PNPBIOS allows the adaptor to
work along with my PCMCIA devices (mostly CompactFlash cards).

This worked in the 2.4 kernels.
Comment 1 Arjan van de Ven 2004-01-03 03:56:02 EST
PNPBIOS is a really really bad option to enable since it crashes on a
lot of machines (and is not needed for ISAPNP operation anyway).

Comment 2 Thomas Dodd 2004-01-03 15:20:08 EST
OK. So PNPBIOS isn't needed. I just turned on all the PNP options, and
it worked.

Still shouldn't ISAPNP be on? Or some support for configuring the
devices? Does turningf on ISAPNP have any sideeffects to warrant
turning it off for most?

Comment 3 Dave Jones 2004-10-26 00:23:22 EDT
enabled in errata.

Note You need to log in before you can comment on or make changes to this bug.