Bug 1127570 - No fish completion
Summary: No fish completion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-io
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 07:31 UTC by Yajo
Modified: 2015-01-22 18:08 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-22 18:08:20 UTC


Attachments (Terms of Use)

Description Yajo 2014-08-07 07:31:20 UTC
Description of problem:
Cannot use autocompletion whith fish shell


Version-Release number of selected component (if applicable):
fish-2.1.0-9.fc20.x86_64
docker-io-1.0.0-9.fc20.x86_64


How reproducible:
Write `docker [TAB]` using fish shell.


Actual results:
Shows directories in CWD.


Expected results:
attach   events   import   load     pull     run      tag      
build    export   info     login    push     save     top      
commit   help     insert   logs     restart  search   version  
cp       history  inspect  port     rm       start    wait     
diff     images   kill     ps       rmi      stop     


Additional info:
Current version of Docker provides it: https://github.com/docker/docker/blob/v1.0.0/contrib/completion/fish/docker.fish

Comment 1 Lokesh Mandvekar 2014-08-07 17:07:47 UTC
Hi,

Can you test this rpm please: https://lsm5.fedorapeople.org/docker-io-1.1.2-3.fc20.x86_64.rpm 

The rawhide version of this doesn't seem to work for me. I see this on fish: 

source: Error while reading file “/usr/share/fish/completions/docker.fish”

Comment 2 Yajo 2014-08-08 07:11:00 UTC
(In reply to Lokesh Mandvekar from comment #1)
> Hi,
> 
> Can you test this rpm please:
> https://lsm5.fedorapeople.org/docker-io-1.1.2-3.fc20.x86_64.rpm 
> 
> The rawhide version of this doesn't seem to work for me. I see this on fish: 
> 
> source: Error while reading file “/usr/share/fish/completions/docker.fish”

The same for me.

The weird thing is that I copied https://raw.githubusercontent.com/docker/docker/v1.0.0/contrib/completion/fish/docker.fish to ~/.config/fish/completions/docker.fish and it worked fine. Well, not as fine as the bash completion, but at least it's something.

Comment 3 Matthew Miller 2014-08-08 13:52:54 UTC
This is problematic. We don't want docker to _require_ fish, but that's what owns the /usr/share/fish/completions directory

Comment 4 Lokesh Mandvekar 2014-08-08 15:16:04 UTC
Hmm, looks like it'd be better to have docker.fish included in upstream fish /fish rpm ? 

(Same should also apply to zsh in that case (my bad))

Comment 5 Yajo 2014-08-19 13:19:58 UTC
That seems to be fish's way: https://github.com/fish-shell/fish-shell/tree/master/share/completions

Other option is to make a separate package.

Comment 6 Lokesh Mandvekar 2014-08-19 16:53:19 UTC
Hmm, looks like docker completion is already in master https://github.com/fish-shell/fish-shell/blob/master/share/completions/docker.fish , so it should probably show up in a fish update

Comment 7 Lokesh Mandvekar 2014-12-17 19:36:07 UTC
I'll be adding fish completion in a docker-fish subpackage.

Comment 8 Lokesh Mandvekar 2014-12-17 19:47:49 UTC
hmm, let me test this before committing to add it :| . My guess is it would conflict with the file already installed via fish.

Comment 9 Lokesh Mandvekar 2015-01-15 21:35:29 UTC
This has been included since 1.4.1-1 though these haven't landed in stable yet. Hopefully we'll get a stable push for 1.4.1-1 soon :|

Comment 10 Yajo 2015-01-16 08:57:34 UTC
(In reply to Lokesh Mandvekar from comment #9)
> This has been included since 1.4.1-1 though these haven't landed in stable
> yet. Hopefully we'll get a stable push for 1.4.1-1 soon :|

I'd love to test it. Could you please add the link for adding karma?

Comment 11 Lokesh Mandvekar 2015-01-16 09:13:24 UTC
(In reply to Yajo from comment #10)
> (In reply to Lokesh Mandvekar from comment #9)
> > This has been included since 1.4.1-1 though these haven't landed in stable
> > yet. Hopefully we'll get a stable push for 1.4.1-1 soon :|
> 
> I'd love to test it. Could you please add the link for adding karma?

assuming you've switched to f21, please test and add karma here: https://admin.fedoraproject.org/updates/FEDORA-2015-0641/docker-io-1.4.1-5.fc21 

if you're still on f20, this is probably the one: https://admin.fedoraproject.org/updates/FEDORA-2015-0451/docker-io-1.4.1-4.fc20 . This version doesn't have the fix for avoiding /.docker (which is coming in a later build for f20), but it should be good RE: fish subpackage.

HTH.

Comment 12 Lokesh Mandvekar 2015-01-22 18:08:20 UTC
So, the f21 build has landed in stable. I'm closing this one.


Note You need to log in before you can comment on or make changes to this bug.