Bug 1127576 - Build default PXE menu shall be POST request instead of GET
Summary: Build default PXE menu shall be POST request instead of GET
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
low vote
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-08-07 07:53 UTC by Peter Vreman
Modified: 2019-04-01 20:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:43:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 6976 None None None 2016-04-22 15:48:29 UTC

Description Peter Vreman 2014-08-07 07:53:09 UTC
Description of problem:
Build default PXE menu is an action that modifies data. Therefor the API request shall be a POST request instead of GET request. This makes it also consistent with the import_puppetclases API call that needs a POST request

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dominic Cleal 2014-08-07 07:57:07 UTC
Created redmine issue http://projects.theforeman.org/issues/6976 from this bug

Comment 3 Bryan Kearney 2015-06-10 18:02:13 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6976 has been closed
-------------
Anonymous
Applied in changeset commit:9250d8b4eb1173b7bfd3eed9bb69ba6a6da4eb5b.

Comment 4 Sachin Ghai 2015-10-20 09:58:59 UTC
Verified with latest upstream build:

foreman-release-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch


[root@cloud-qe-XX ~]# curl -k -u admin:changeme  -H "Content-Type: application/json" -X POST 'https://foreman-server/api/v2/config_templates/build_pxe_default'
{"message":"PXE Default file has been deployed to all Smart Proxies"}[root@cloud-qe-XX ~]# 

Now build default pxe is now a POST request.

Comment 7 errata-xmlrpc 2016-07-27 08:43:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.