Bug 1127599 - When running: engine-config -s "CustomDeviceProperties={type=interface;prop={other-nic-properties;queues=[0-9]*}}", provides an error only after asking to select a version
Summary: When running: engine-config -s "CustomDeviceProperties={type=interface;prop={...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-config
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Eli Mesika
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 08:38 UTC by Michael Burman
Modified: 2016-02-10 19:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 04:49:50 UTC
oVirt Team: Infra


Attachments (Terms of Use)
Print screen (321.53 KB, image/png)
2014-08-07 08:38 UTC, Michael Burman
no flags Details

Description Michael Burman 2014-08-07 08:38:57 UTC
Created attachment 924788 [details]
Print screen

Description of problem:
When running engine-config -s "CustomDeviceProperties={type=interface;prop={other-nic-properties;queues=[0-9]*}}". An error appears only after providing a vesrion. The error should be displayed before that. right away, if the engine-config command is wrong.

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.Run command - engine-config -s "CustomDeviceProperties={type=interface;prop={other-nic-properties;queues=[0-9]*}}"
2. 
3.

Actual results:
After running the command, you asked to provide a version, and in this point you thing that the command is right. but after providing the version, you got an error.

Expected results:
If the engine-config -s command is wrong, the error should be right away. 

Additional info:

Comment 1 Eli Mesika 2014-08-10 20:36:19 UTC
I don't think this is a bug.
The reason you are asked for the version is because you didn't gave it in the command line using the --cver option.
With --cver, you got the error immediately

---snip---
engine-config -s "CustomDeviceProperties={type=interface;prop={other-nic-properties;queues=[0-9]*}}" --cver=3.1
Cannot set value {type=interface;prop={other-nic-properties;queues=[0-9]*}} to key CustomDeviceProperties. Device custom properties are not supported in version 3.1
---snip---

You can not do the verification before getting the version since format can be changed between versions so you will not be able to know which format to match unless you got the version

I think this should be closed as NOTABUG 

Oved?

Comment 2 Oved Ourfali 2014-08-11 04:49:50 UTC
I think you're right. 
Closing as notabug.


Note You need to log in before you can comment on or make changes to this bug.