Bug 1127606 - [foreman integration] Get generic error when adding discovered host without picking Host Group\Compute Resource
Summary: [foreman integration] Get generic error when adding discovered host without p...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Yaniv Bronhaim
QA Contact: sefi litmanovich
URL:
Whiteboard: infra
: 1124870 (view as bug list)
Depends On:
Blocks: rhev3.5beta3
TreeView+ depends on / blocked
 
Reported: 2014-08-07 08:48 UTC by Tareq Alayan
Modified: 2016-02-10 19:05 UTC (History)
12 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:13:19 UTC
oVirt Team: Infra


Attachments (Terms of Use)
logs (39.53 KB, application/x-tar-gz)
2014-08-07 08:48 UTC, Tareq Alayan
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31178 master MERGED ui: Adding fields validation in addHost form Never
oVirt gerrit 31287 master MERGED core: Add validation for empty compute resource or host group Never
oVirt gerrit 33093 ovirt-engine-3.5 MERGED ui: Adding fields validation in addHost form Never
oVirt gerrit 33094 ovirt-engine-3.5 MERGED core: Add validation for empty compute resource or host group Never

Description Tareq Alayan 2014-08-07 08:48:16 UTC
Description of problem:
internal engine error when attempting to add a host from foreman

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
foreman-1.6.0.32-1.el6sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. have a foreman up and running
2. go to add new host dialogue select foreman discovered
3. provide password and click add

Actual results:
internal engine error

Expected results:
adding host or a descriptive error message 

Additional info:

Comment 1 Tareq Alayan 2014-08-07 08:48:38 UTC
Created attachment 924801 [details]
logs

Comment 2 Yaniv Bronhaim 2014-08-07 11:05:37 UTC
*** Bug 1124870 has been marked as a duplicate of this bug. ***

Comment 3 Eyal Edri 2014-09-28 11:29:35 UTC
this bug was moved to MODIFIED before vt4 build date thus moving to ON_QA.
if you belive this bug isn't in vt4, please report to rhev-integ@redhat.com

Comment 4 sefi litmanovich 2014-10-22 12:17:44 UTC
verified with rhevm-3.5.0-0.15.beta.el6ev.noarch.

If foreman has a host group and compute resource configured it will display them on the relevant field at the add host menu.
If not when trying to add host the field is is red and add host isn't possible.

Comment 5 Eyal Edri 2015-02-17 17:13:19 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.