Bug 1127642 - ERROR [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] - RunVmCommand.java:945
Summary: ERROR [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] - RunVmCommand.java:945
Keywords:
Status: CLOSED DUPLICATE of bug 1040952
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Arik
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 09:47 UTC by Jiri Belka
Modified: 2016-02-10 19:50 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 08:43:36 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine.log (129.13 KB, application/x-gzip)
2014-08-07 09:47 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2014-08-07 09:47:34 UTC
Created attachment 924833 [details]
engine.log

Description of problem:

2014-08-07 11:27:24,734 ERROR [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (org.ovirt.thread.pool-8-thread-22) [within thread]: endAction for action type RunVm threw an exception.: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.RunVmCommand.createContextForRunStatelessVm(RunVmCommand.java:945) [bll.jar:]
        at org.ovirt.engine.core.bll.RunVmCommand.endSuccessfully(RunVmCommand.java:927) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.internalEndSuccessfully(CommandBase.java:611) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.endActionInTransactionScope(CommandBase.java:556) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1876) [bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:174) [utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:116) [utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.endAction(CommandBase.java:487) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.DecoratedCommand.endAction(DecoratedCommand.java:17) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CoCoAsyncTaskHelper.endAction(CoCoAsyncTaskHelper.java:317) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandCoordinatorImpl.endAction(CommandCoordinatorImpl.java:350) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.EndCommandAction(CommandAsyncTask.java:149) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.access$000(CommandAsyncTask.java:28) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandAsyncTask$1.run(CommandAsyncTask.java:109) [bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:90) [utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_55]
        at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_55]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_55]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_55]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_55]

Version-Release number of selected component (if applicable):
ovirt-engine-backend-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. create a pool with 7 vms
2. define 6 for prestarted
3. immediately when the dialog closes restart engine from cli

Actual results:
NPE in the log

Expected results:
???

Additional info:

Comment 1 Oved Ourfali 2014-08-10 06:37:06 UTC
Omer - if it looks like an infra issue then contact Ravi for help.

Comment 2 Michal Skrivanek 2014-08-13 08:43:36 UTC
this is caused by an incomplete fix for bug 1040952. Will be tracked as part of that one

*** This bug has been marked as a duplicate of bug 1040952 ***


Note You need to log in before you can comment on or make changes to this bug.