Bug 1127648 - TUI shows "No virtualization hardware was detected on this system" while you actually enabled it
Summary: TUI shows "No virtualization hardware was detected on this system" while you ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
: 1128124 (view as bug list)
Depends On: rebase-ovirt-node-3.1
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-08-07 09:55 UTC by wanghui
Modified: 2016-02-10 20:11 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:01:01 UTC
oVirt Team: Node


Attachments (Terms of Use)
"No virtualization hardware was detected on this system" warning info (52.52 KB, image/png)
2014-08-07 09:55 UTC, wanghui
no flags Details
more cpu infos (2.01 KB, application/gzip)
2014-08-07 12:42 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 31205 master MERGED utils: Fix virt state detection Never

Description wanghui 2014-08-07 09:55:37 UTC
Created attachment 924844 [details]
"No virtualization hardware was detected on this system" warning info

Description of problem:
It reports "No virtualization hardware was detected on this system" when you install it while you actually enabled it. And the warning info also display in Status page.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140806.1.iso
ovirt-node-3.1.0-0.7.20140806gitef5c5cb.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. TUI install rhev-hypervisor7-7.0-20140806.1.iso
2. Check the first installation step

Actual results:
1. It reports "No virtualization hardware was detected on this system" while actually you have enabled virtualization function.

Expected results:
1. It should have no such warning if you have enabled virtualization function.

Additional info:

Comment 1 Fabian Deutsch 2014-08-07 10:28:18 UTC
Could you please provide

cat /proc/cpuinfo
and
cat /proc/modules
and
ls /dev/kvm

Comment 2 wanghui 2014-08-07 12:42:50 UTC
Created attachment 924899 [details]
more cpu infos

Provide in attachment. And through first screen shot, it also report 'Failed to Establish Libvirt Connection' error.

Comment 3 Fabian Deutsch 2014-08-07 13:06:50 UTC
Hui, thanks for the quick response.

Comment 4 Fabian Deutsch 2014-08-11 10:39:55 UTC
*** Bug 1128124 has been marked as a duplicate of this bug. ***

Comment 5 wanghui 2014-10-17 06:04:37 UTC
Test version:
rhevh-7.0-20141006.0.el7ev.iso
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch

Test step;
1. TUI install rhev-hypervisor7-7.0-20140806.1.iso
2. Check the first installation step
3. After finish installation, check status page.

Test result:
1. After step2, it shows as "Virtualization hardware was detected and is enabled".
2. After ste3, it shows as "Virtualization hardware was detected and is enabled".


So this issue is fixed in ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch. Change the status from ON_QA to Verified.

Comment 8 errata-xmlrpc 2015-02-11 21:01:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.