Bug 1127653 - Memory leaks of xdata on some fops of protocol/server
Summary: Memory leaks of xdata on some fops of protocol/server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 10:00 UTC by Xavi Hernandez
Modified: 2015-05-14 17:43 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:27:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-08-07 10:00:11 UTC
Description of problem:

Currently, server3_3_(f)setxattr, server3_3_(f)xattrop and server3_3_statfs of protocol/server do not free allocated space for xdata. However xdata in these fops seems to be NULL allways, so the impact of the memory leak is minimum.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-08-08 07:51:17 UTC
REVIEW: http://review.gluster.org/8434 (protocol/server: Fix possible memory leaks of xdata) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-09-08 13:31:22 UTC
REVIEW: http://review.gluster.org/8434 (protocol/server: Fix possible memory leaks of xdata) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Anand Avati 2014-09-11 10:00:31 UTC
REVIEW: http://review.gluster.org/8434 (protocol/server: Fix possible memory leaks of xdata) posted (#3) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 4 Anand Avati 2014-11-17 08:37:35 UTC
REVIEW: http://review.gluster.org/8434 (protocol/server: Fix possible memory leaks of xdata) posted (#4) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 5 Anand Avati 2014-11-17 10:33:03 UTC
REVIEW: http://review.gluster.org/8434 (protocol/server: Fix possible memory leaks of xdata) posted (#5) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 6 Anand Avati 2015-01-09 17:43:38 UTC
COMMIT: http://review.gluster.org/8434 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 71844788a1da0249201b27109e3ea00599569b93
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Fri Aug 8 09:47:10 2014 +0200

    protocol/server: Fix possible memory leaks of xdata
    
    There was a memory leak of xdata argument in fops (f)setxattr,
    (f)xattrop and statfs. This leak was minor because xdata is
    rarely, or even not used at all, in this fops.
    
    Change-Id: Ie1083ae227755a11cf72f8d89595520a5afb3042
    BUG: 1127653
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8434
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 7 Niels de Vos 2015-05-14 17:27:02 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:35:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:37:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:43:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.