Bug 1127670 - Prestarted VMs are not started all together in one shot
Summary: Prestarted VMs are not started all together in one shot
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: bugs@ovirt.org
QA Contact: meital avital
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 10:28 UTC by Jiri Belka
Modified: 2016-02-10 19:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-29 11:45:14 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine.log (95.69 KB, application/x-gzip)
2014-08-07 10:28 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2014-08-07 10:28:09 UTC
Created attachment 924866 [details]
engine.log

Description of problem:
Prestarted VMs are not started all together in one shot. The prestarted value is '6' but first only 4 VMs are started then some minutes later the rest of them. This is odd.

2014-Aug-07, 12:18
VM thepool-5 was restarted on Host dell-r210ii-03 as stateless
	
2014-Aug-07, 12:18
VM thepool-2 was restarted on Host dell-r210ii-03 as stateless
	
2014-Aug-07, 12:17
VM thepool-5 was restarted on Host <UNKNOWN>
	
2014-Aug-07, 12:17
VM thepool-2 was restarted on Host <UNKNOWN>
	
2014-Aug-07, 12:13
VM thepool-4 was restarted on Host dell-r210ii-03 as stateless
	
2014-Aug-07, 12:13
VM thepool-1 was restarted on Host dell-r210ii-03 as stateless
	
2014-Aug-07, 12:13
VM thepool-3 was restarted on Host dell-r210ii-03 as stateless
	
2014-Aug-07, 12:13
VM thepool-6 was restarted on Host dell-r210ii-03 as stateless
	
2014-Aug-07, 12:12
VM thepool-1 was restarted on Host <UNKNOWN>
	
2014-Aug-07, 12:12
VM thepool-4 was restarted on Host <UNKNOWN>
	
2014-Aug-07, 12:12
VM thepool-3 was restarted on Host <UNKNOWN>
	
2014-Aug-07, 12:12
VM thepool-6 was restarted on Host <UNKNOWN>
	
2014-Aug-07, 12:12
Starting VM thepool-7 as stateless was initiated.

Version-Release number of selected component (if applicable):
ovirt-engine-backend-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. create a pool with 7 vms
2. define 6 as prestarted
3. after the dialog is closed, restart the engine from cli

Actual results:
later on prestarted vms are not started in one shot

Expected results:
start in one shot, time is money

Additional info:

Comment 1 Michal Skrivanek 2014-08-22 14:16:01 UTC
VMs are prestarted as fast as they can. Sometimes you get a contention on resources which are resolved after some time, hence next retry succeeds to run some more (maybe still  not all), etc…

any specific complaint?

Comment 2 Jiri Belka 2014-08-26 08:48:41 UTC
if it is like it should work by design then i cannot complain, right? iiuc to speed it up only solution is to modify

VmPoolMonitorIntervalInMinutes: 5 version: general
VmPoolMonitorBatchSize: 5 version: general

feel free to close the BZ if there's nothing suspicious in the logs.

Comment 3 Michal Skrivanek 2014-08-29 11:45:14 UTC
you can complain as much as you want:-)
no, nothing else suspicious there...


Note You need to log in before you can comment on or make changes to this bug.