Bug 112768 - Graphical boot does not work after update from RH 9.0
Graphical boot does not work after update from RH 9.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-30 19:24 EST by Mark Lorenzen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-18 16:47:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Lorenzen 2003-12-30 19:24:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
System is updated from Red Hat Linux 9.0. When booting the system, the
/usr/bin/rhgb program is run, but the program fails with an error
message before a graphical boot screen appears.

Version-Release number of selected component (if applicable):
0.11.2-1

How reproducible:
Always

Steps to Reproduce:
1. Update to Fedora Core 1 from Red Hat Linux 9.0.
2. Choose to use a graphical boot.
3. Reboot the system after update.

Actual Results:  The /usr/bin/rhgb program is run, but prints the
following error message:

umount2: Invalid argument
umount: /initrd: not mounted
umount2: Invalid argument
umount: /initrd: not mounted

Expected Results: A graphical boot screen.

Additional info:

When trying to run the /usr/bin/rhgb program, after the system has
booted, then the same error message as above is printed.
Comment 1 Andrew Forgue 2004-01-12 08:00:35 EST
I can also reproduce this error.  However I did not upgrade from 9.0;
I did a minimal net installation and then installed rhgb later.  I
made the above changes and this error appeared.

But running 'rhgb -f' does load the splash screen after boot, and if I
edit /etc/rc.d/rc.sysinit to add '-f' there is no effect (the error is
gone, though).
Comment 2 Warren Togami 2004-03-07 04:45:52 EST
Just to confirm, your /boot/grub/grub.conf contains "rhgb" within the
kernel line?

Is this issue solved by recent FC1 updates by chance?
Comment 3 Mark Lorenzen 2004-03-07 08:03:05 EST
I can confirm that my /boot/grub/grub.conf contains "rhgb" within the
kernel line. When removing the "rhgb" parameter, the above mentioned
error message is not shown (but of course there is no graphical boot
either).

The system is completely up-to-date, but the problem persists.
Comment 4 Need Real Name 2004-05-11 14:55:29 EDT
This may be an issue with the default run-level not being set to "5";
I ran into this error, and resolved it by setting the default
run-level from 3->5, so if that is the true fix, rhgb probably needs
to handle that case a little more gracefully.
Comment 5 Mark Lorenzen 2004-05-11 17:06:24 EDT
That solved it. After changing the runlevel to 5, the error message is
gone and the system boots in graphical mode. Once booted, I get to
finish the installation (accepting the license etc.) although it is
over 4 months since I installed FC1.

So I propably chose to use graphical boot when I upgraded from RH9,
but my default runlevel was not updated.
Comment 6 Daniel Veillard 2004-09-18 16:47:14 EDT
we need to be sure that we are booting in run level 5, be it
that default run level is set to 5 in inittab or that 5 is 
passed on the kernel command line.
I don't think it's a bug, fedora default to 5 if you enable
everything needed to run X.

Daniel
Comment 7 Warren Togami 2004-09-18 19:37:11 EDT
The system shouldn't be attempting to run rhgb if default runlevel is
3.  That would be an actual bug if it is currently trying to do so.
Comment 8 Daniel Veillard 2004-09-20 06:10:19 EDT
The check of the command line was added on purpose. If you add 5
to your command line then that mean you know what you're doing,
this is not the default.
I disagree with your caracterization as a bug, and since you 
didn't explained why the status quo will stay.

Daniel

Note You need to log in before you can comment on or make changes to this bug.