Bug 1127682 - Report an error when change network from vlan tagged to vlan untagged
Summary: Report an error when change network from vlan tagged to vlan untagged
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-08-07 10:48 UTC by wanghui
Modified: 2016-02-10 20:04 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:01:06 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 32341 master MERGED network: use iproute instead of vconfig Never

Description wanghui 2014-08-07 10:48:02 UTC
Description of problem:
It reports error as follows when change network from vlan tagged to vlan untagged.
================================================================================
Checking pre-conditions ...
(1/4) Stop network services
(2/4) Remove existing configuration

An error occurred while applying the changes:
[Errno 2] No such file or directory
================================================================================

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140806.1.iso
ovirt-node-3.1.0-0.7.20140806gitef5c5cb.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. TUI install rhev-hypervisor7-7.0-20140806.1.iso
2. Enable Network with ipv4 dhcp mode and vlan 20
3. Change the network configuration to just ipv4 dhcp mode

Actual results:
1. It reports error as follows after step3.
================================================================================
Checking pre-conditions ...
(1/4) Stop network services
(2/4) Remove existing configuration

An error occurred while applying the changes:
[Errno 2] No such file or directory
================================================================================

Expected results:
1. It should configure network succeed.

Additional info:

Comment 2 wanghui 2014-10-13 06:22:39 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm

Test step:
1. TUI install rhev-hypervisor7-7.0-20140806.1.iso
2. Enable Network with ipv4 dhcp mode and vlan 20
3. Change the network configuration to just ipv4 dhcp mode

Test result:
1. No error occured and NIC with ipv4 dhcp can be configured.

So this issue is fixed in ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm. Change the status from ON_QA to Verified.

Comment 5 errata-xmlrpc 2015-02-11 21:01:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.