Bug 1127685 - Host life cycle broken for jsonrpc
Summary: Host life cycle broken for jsonrpc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Piotr Kliczewski
QA Contact: Antonin Pagac
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 10:56 UTC by Piotr Kliczewski
Modified: 2016-02-10 19:34 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:23:56 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31186 master MERGED core: Host life cycle broken for jsonrpc Never
oVirt gerrit 31187 ovirt-engine-3.5 MERGED core: Host life cycle broken for jsonrpc Never

Description Piotr Kliczewski 2014-08-07 10:56:14 UTC
When engine looses connectivity with vdsm host state do not change to Connecting and Non-Operational.


How reproducible:


Steps to Reproduce:
1. Install new host using jsonrpc (check that host is in 'UP' state)
2. stop vdsm
3. Check that host state hasn't changed.

Actual results:
The host state should change to Connection and later to Non-Operational state.

Expected results:
Host state changes as descirbed above.

Additional info:

Comment 1 Antonin Pagac 2014-09-10 10:52:19 UTC
Marking as verified.

I installed new Host with json-rpc (status 'Up') and killed vdsm and supervdsmServer. Engine reacted to this after a minute or so, and set the status of the Host to 'Connecting'. The same can be found in engine.log. In engine events I can see message 'Host Host is non responsive.', which presents a bit of inconsistency. Almost immediately after Engine set the status to 'Connecting', it started vdsm and supervdsmServer on the Host, and after approx. 20 minutes the Engine set the status of the Host to 'Up'.

I'm marking this as verified, because Engine changes Host state as it should.

oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6

Comment 2 Sandro Bonazzola 2014-10-17 12:23:56 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.