Bug 1127687 - Labels should be filtered by product (RHEV/Neutron)
Summary: Labels should be filtered by product (RHEV/Neutron)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: GenadiC
URL:
Whiteboard: network
Depends On: 1077132
Blocks: 1102906
TreeView+ depends on / blocked
 
Reported: 2014-08-07 10:58 UTC by Lior Vernia
Modified: 2016-02-10 19:53 UTC (History)
17 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1077132
Environment:
Last Closed: 2015-02-17 17:14:07 UTC
oVirt Team: Network


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26001 None None None Never
oVirt gerrit 26033 None None None Never
oVirt gerrit 27119 None None None Never
oVirt gerrit 31680 master MERGED core: Don't store Neutron physical network on import Never
oVirt gerrit 31702 ovirt-engine-3.5 MERGED core: Don't store Neutron physical network on import Never

Description Lior Vernia 2014-08-07 10:58:07 UTC
+++ This bug was initially created as a clone of Bug #1077132 +++

Description of problem:
Network labels for RHEV and for Neutron should not be mixed when creating a network and attaching a label to it.
For RHEV network only RHEV labels should be presented for newly created network and for Neutron network only Neutron labels

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create network with external provider and label 'vlan_ranges'
2. Create RHEV network(without external provider checkbox checked) 
3. Choose label for RHEV network

Actual results:
From the list of labels presented for RHEV network there is 'vlan_ranges' label as well

Expected results:
'vlan_ranges' label should be presented only when 'external provider' checkbox is checked

Additional info:

--- Additional comment from Lior Vernia on 2014-03-18 07:25:45 EDT ---

I suspect this is due to a backend query returning ALL labels that exist in the DC, rather than just "internal" labels.

--- Additional comment from Yevgeny Zaspitsky on 2014-03-24 07:46:12 EDT ---

According to Mike the solution should be aoiding storing the external labels in the ovirt DB

--- Additional comment from GenadiC on 2014-05-12 10:03:11 EDT ---

Verified in av9

--- Additional comment from Itamar Heim on 2014-06-12 10:10:44 EDT ---

Closing as part of 3.4.0

--- Additional comment from GenadiC on 2014-08-05 03:19:36 EDT ---

Configure new external network with its label
Add a new network:
a) If it is external network the label is not seen, but should
b) if it isn't external network the label is seen and it shouldn't

--- Additional comment from RHEL Product and Program Management on 2014-08-05 03:22:11 EDT ---

This bug report has Keywords: Regression or TestBlocker.

Since no regressions or test blockers are allowed between releases,
it is also being identified as a blocker for this release.

Please resolve ASAP.

--- Additional comment from Lior Vernia on 2014-08-07 06:55:54 EDT ---

Closing and cloning for 3.5...

Comment 2 Lior Vernia 2014-08-07 11:06:03 UTC
To my understanding (a) is not really a problem - it's (sort of) a duplicate of Bug 995850. However, (b) is strange because I thought we weren't keeping any track of Neutron labels in our DB?

Comment 3 Lior Vernia 2014-08-19 10:52:16 UTC
One issue is definitely that in OpenstackNetworkProviderProxy, the Neutron physical network is mapped to our oVirt label - this code should be removed if we don't plan to store Neutron physical network data in our DB.

Comment 4 GenadiC 2014-08-24 08:05:10 UTC
Verified in ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch

Comment 5 Eyal Edri 2015-02-17 17:14:07 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.