Bug 1127727 - [Networks]>Empty Description should be part of Sorting, just like The Behavior in the sub-tab vNIC profiles
Summary: [Networks]>Empty Description should be part of Sorting, just like The Behavio...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: 3.6.0
Assignee: Ori Liel
QA Contact: Michael Burman
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 12:22 UTC by Michael Burman
Modified: 2016-02-10 19:30 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 13:56:01 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 42546 master ABANDONED engine: Consider empty values in engine sorting(#1127727) 2016-01-31 01:55:22 UTC
Red Hat Bugzilla 1243444 None None None Never

Internal Links: 1243444

Description Michael Burman 2014-08-07 12:22:13 UTC
Description of problem:
In the main tub [Networks] the empty description is not part of the sorting, always stays below. but in the sub-tab vNIC profiles, empty description is part of the sorting and this is a good behavior. The main tub should behave the same.

Version-Release number of selected component (if applicable):
 oVirt Engine Version: 3.5.0-0.0.master.20140804172041.git23b558e.el6 

How reproducible:
always

Steps to Reproduce:
1. Create few new networks, with different description names and some with empty description. try sorting by description.
2.
3.

Actual results:
The empty description is not sorted and stays always below.

Expected results:
Empty description should be part of the sorting. Like in the sub-tab vNIC profiles.

Additional info:

Comment 1 Lior Vernia 2014-08-10 11:09:39 UTC
Known issue with tabs using the backend sorting mechanism, not sure if there's another bug open on this or not.

Comment 2 Einav Cohen 2014-09-11 17:19:11 UTC
not sure what the correct behavior is here: should empty values always be at the end (in this case, client sorting should be fixed) or should empty values be treated just like any other value and appear where it makes sense, i.e. at the beginning of the list for an ascending sorting order, at the end of the list for a descending sorting order (in this case, server sorting should be fixed and BZ need to be re-assigned to 'infra')?

Comment 3 Einav Cohen 2015-04-20 12:24:02 UTC
@Liz - do you recall if we ended up reaching a decision on whether sorting by a field that contains empty values should contain the empty values as part of the sort, or should empty values always be pushed to the end?

Comment 4 Liz 2015-04-20 15:31:53 UTC
@Einav - I think it makes sense for empty values to be included in the sorting in the case where the user might want to raise any empty values to the top of the list.

Comment 5 Einav Cohen 2015-04-20 16:17:25 UTC
(In reply to Liz from comment #4)
> @Einav - I think it makes sense for empty values to be included in the
> sorting in the case where the user might want to raise any empty values to
> the top of the list.

thanks, Liz. 
Per comment #5, moving to 'infra' (search should be changed to include empty values in the sort, rather than always pushing records with empty values to the end of the sorted list).

Comment 6 Ori Liel 2015-06-18 11:49:17 UTC
patch posted: 

  https://gerrit.ovirt.org/#/c/42546/

Comment 7 Ori Liel 2015-06-18 14:46:25 UTC
Eli enlightened me that this requirement seems to contradict with the requirement in: 
  
  https://bugzilla.redhat.com/show_bug.cgi?id=962560

IMO either we want to consider empty values, or we don't, but whichever it is, it should apply to all tabs. Scott, what do you think?

Comment 8 Einav Cohen 2015-07-16 13:59:59 UTC
'needinfo'ing Yaniv/Moran, that may be able to chime in on the question in Comment #7 as well (relevant for bug 1243444 too).

Comment 9 Yaniv Lavi 2015-07-21 22:42:17 UTC
Since Liz said that the correct ux here is to sort the nulls, if think we should go with that. Seems more correct to me as well, but not major issue as I see it.

Comment 10 Einav Cohen 2015-07-22 11:45:08 UTC
so need to simply include nulls as part of the sort; 
so if sort is ascending, nulls should be first; if sort is descending - nulls should be last. 

this should be modified in the search mechanism.

Comment 11 Ori Liel 2015-07-30 13:01:35 UTC
solved by https://bugzilla.redhat.com/1243444

Comment 12 Michael Burman 2015-07-30 13:28:09 UTC
Verified on - 3.6.0-0.0.master.20150726172446.git65db93d.el6

Comment 13 Sandro Bonazzola 2015-11-04 13:56:01 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.