Bug 1127747 - Can't delete an org if it has a published content view: can't modify frozen Hash
Summary: Can't delete an org if it has a published content view: can't modify frozen Hash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 13:05 UTC by David Davis
Modified: 2016-04-22 16:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:30:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6985 None None None 2016-04-22 16:24:14 UTC

Description David Davis 2014-08-07 13:05:20 UTC
Getting this error:

Could not delete the organization:
  can't modify frozen Hash


Basically, create a content view with puppet modules, publish it, and promote it to some environments. They try to delete the org.

Comment 2 David Davis 2014-08-07 13:42:08 UTC
Looks like you don't even need puppet modules.

Comment 5 Partha Aji 2014-08-07 15:07:22 UTC
Created redmine issue http://projects.theforeman.org/issues/6985 from this bug

Comment 6 David Davis 2014-08-07 16:08:15 UTC
Steps to reproduce:

1. Create an org with an extra env (eg Dev)
2. Create a content view w/ a synced repo
3. Publish and promote the content view to Dev
4. Remove org

Comment 7 David Davis 2014-08-07 16:08:24 UTC
https://github.com/Katello/katello/pull/4545

Comment 8 Bryan Kearney 2014-08-11 16:05:08 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6985 has been closed
-------------
David Davis
Applied in changeset commit:katello|58e2ca067a78e59d20229c890a1877d30843b343.

Comment 11 Corey Welton 2014-08-15 21:43:53 UTC
Verified in Satellite-6.0.4-RHEL-6-20140813.2

Comment 12 Bryan Kearney 2014-09-11 12:30:08 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.